summaryrefslogtreecommitdiff
path: root/documentation/adt-manual/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2011-03-14 14:19:44 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-16 13:38:02 +0000
commitac2c8848bbefcf7d24192573904baaef87c67382 (patch)
tree3300084af930dfce3525c5e7d7c997d0afd2b9e8 /documentation/adt-manual/Makefile
parent79f160a7ac9426ec9952f7a9c40190da8b95c88d (diff)
downloadopenembedded-core-ac2c8848bbefcf7d24192573904baaef87c67382.tar.gz
openembedded-core-ac2c8848bbefcf7d24192573904baaef87c67382.tar.bz2
openembedded-core-ac2c8848bbefcf7d24192573904baaef87c67382.tar.xz
openembedded-core-ac2c8848bbefcf7d24192573904baaef87c67382.zip
documentation/adt-manual: New file structure for ADT Manual
I have added a new directory to documentation named adt-manual. This directory holds a Figures folder, and the 9 files needed for the ADT manual. The book consists of five chapters: adt-intro, adt-prepare, adt-package, adt-eclipse, and adt-command. There is also a adt-manual.xml file called by the Makefile. There is also a style.css file. And finally, a adt-manual-customization.xsl file to control numbering. Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
Diffstat (limited to 'documentation/adt-manual/Makefile')
-rw-r--r--documentation/adt-manual/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/documentation/adt-manual/Makefile b/documentation/adt-manual/Makefile
new file mode 100644
index 000000000..dcfcb9231
--- /dev/null
+++ b/documentation/adt-manual/Makefile
@@ -0,0 +1,42 @@
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
+
+all: html pdf tarball
+
+pdf:
+ ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+
+# xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
+ xsltproc $(XSLTOPTS) -o kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
+
+tarball: html
+ tar -cvzf kernel-manual.tgz kernel-manual.html style.css figures/kernel-title.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+
+validate:
+ xmllint --postvalid --xinclude --noout kernel-manual.xml
+
+OUTPUTS = kernel-manual.tgz kernel-manual.html kernel-manual.pdf
+SOURCES = *.png *.xml *.css
+
+publish:
+ scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
+
+clean:
+ rm -f $(OUTPUTS)