summaryrefslogtreecommitdiff
path: root/documentation/kernel-manual/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2010-11-24 08:31:55 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-12-10 22:01:07 -0800
commit000f052765577826907ff1e3f758bab3a0724d74 (patch)
treed24d2bcb667aae24a63be1b5184ef2f29580d60b /documentation/kernel-manual/Makefile
parentaa583453935a13618f0068fdf8d6d3205725ec54 (diff)
downloadopenembedded-core-000f052765577826907ff1e3f758bab3a0724d74.tar.gz
openembedded-core-000f052765577826907ff1e3f758bab3a0724d74.tar.bz2
openembedded-core-000f052765577826907ff1e3f758bab3a0724d74.tar.xz
openembedded-core-000f052765577826907ff1e3f758bab3a0724d74.zip
documentation/kerenl-manual: New directory and files for kernel manual.
This is the first draft of the Yocto Project Kernel manual. The manual consists of two sections: concepts and a practical section that has examples. It is based of Bruce Ashfield's kernel theory paper. This first draft has been re-written and organized through the concepts section. The remainder was just placed in as-is due to time constraints for getting some kernel documentation up on the website. The manual still needs scrubbing and organization in the latter half. Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
Diffstat (limited to 'documentation/kernel-manual/Makefile')
-rw-r--r--documentation/kernel-manual/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/documentation/kernel-manual/Makefile b/documentation/kernel-manual/Makefile
new file mode 100644
index 000000000..701bddfa7
--- /dev/null
+++ b/documentation/kernel-manual/Makefile
@@ -0,0 +1,32 @@
+XSLTOPTS = --stringparam html.stylesheet style.css \
+ --xinclude
+
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
+
+all: html tarball
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+
+html:
+# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
+
+# xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
+ xsltproc $(XSLTOPTS) -o yocto-project-kernal-manual.html yocto-project-kernal-manual-customization.xsl yocto-project-kernal-manual.xml
+
+tarball: html
+ tar -cvzf yocto-project-kernal-manual.tgz yocto-project-kernal-manual.html style.css figures/yocto-project-transp.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+
+validate:
+ xmllint --postvalid --xinclude --noout yocto-project-kernal-manual.xml
+
+OUTPUTS = yocto-project-kernal-manual.tgz yocto-project-kernal-manual.html
+SOURCES = *.png *.xml *.css
+
+publish:
+ scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
+
+clean:
+ rm -f $(OUTPUTS)