summaryrefslogtreecommitdiff
path: root/documentation/poky-ref-manual/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2010-11-04 13:01:19 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-04 20:54:30 +0000
commit890a794e38f2d11ec0dd6e39e5ab77a929cb51d9 (patch)
tree75a69ef3e6752085f5bc1a3d84fab378af5b515a /documentation/poky-ref-manual/Makefile
parent4b7f1eee28dafcb237f54e1739a9936fdd80ebc4 (diff)
downloadopenembedded-core-890a794e38f2d11ec0dd6e39e5ab77a929cb51d9.tar.gz
openembedded-core-890a794e38f2d11ec0dd6e39e5ab77a929cb51d9.tar.bz2
openembedded-core-890a794e38f2d11ec0dd6e39e5ab77a929cb51d9.tar.xz
openembedded-core-890a794e38f2d11ec0dd6e39e5ab77a929cb51d9.zip
Created a new folder to hold the BSP Guide
I created a new sub folder to hold the BSP Guide by itself so there are three folders now for each of the Yocto manuals: BSP Guide, quick start and poky ref manual. The new folder for the BSP guide is 'bsp-guide'. It contains the bsp.xml file, its own Makefile, a bsp-guide.xml file, and its own 'Figures' directory. The 'bsp-guide.xml' file that was in the poky reference folder was deleted. Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
Diffstat (limited to 'documentation/poky-ref-manual/Makefile')
-rw-r--r--documentation/poky-ref-manual/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/documentation/poky-ref-manual/Makefile b/documentation/poky-ref-manual/Makefile
index a5a331bd5..c906c7deb 100644
--- a/documentation/poky-ref-manual/Makefile
+++ b/documentation/poky-ref-manual/Makefile
@@ -2,7 +2,6 @@ all: html pdf tarball
pdf:
../tools/poky-docbook-to-pdf poky-ref-manual.xml ../template
- ../tools/poky-docbook-to-pdf bsp-guide.xml ../template
XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam chapter.autolabel 1 \
@@ -20,15 +19,14 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
xsltproc $(XSLTOPTS) -o poky-ref-manual.html $(XSL_XHTML_URI) poky-ref-manual.xml
- xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
tarball: html
- tar -cvzf poky-ref-manual.tgz poky-ref-manual.html style.css figures/yocto-project-transp.png figures/poky-ref-manual.png
+ tar -cvzf poky-ref-manual.tgz poky-ref-manual.html style.css figures/yocto-project-transp.png figures/poky-ref-manual.png screenshots/ss-sato.png
validate:
xmllint --postvalid --xinclude --noout poky-ref-manual.xml
-OUTPUTS = poky-ref-manual.tgz poky-ref-manual.html poky-ref-manual.pdf bsp-guide.pdf bsp-guide.html
+OUTPUTS = poky-ref-manual.tgz poky-ref-manual.html poky-ref-manual.pdf
SOURCES = *.png *.xml *.css *.svg
publish: