summaryrefslogtreecommitdiff
path: root/handbook/examples/hello-single/hello.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
commit882e9cd2affb773eec8b1d387ab4e3b5cbdc0994 (patch)
treef023b2ce9abf3b894a81986e0a00e23d77b55e66 /handbook/examples/hello-single/hello.bb
parent7197110f46511492a48cd359b3ddf75b60ea47c8 (diff)
downloadopenembedded-core-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.tar.gz
openembedded-core-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.tar.bz2
openembedded-core-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.tar.xz
openembedded-core-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.zip
Add Poky handbook
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3865 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'handbook/examples/hello-single/hello.bb')
-rw-r--r--handbook/examples/hello-single/hello.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/handbook/examples/hello-single/hello.bb b/handbook/examples/hello-single/hello.bb
new file mode 100644
index 000000000..d815b1ed7
--- /dev/null
+++ b/handbook/examples/hello-single/hello.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Simple helloworld application"
+SECTION = "examples"
+LICENSE = "MIT"
+
+SRC_URI = "file://helloworld.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} helloworld.c -o helloworld
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}
+}