summaryrefslogtreecommitdiff
path: root/meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-21 17:31:45 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 22:39:43 +0100
commite8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304 (patch)
treec8ed16e490e2e30de292c8a10eedb084d5abdea8 /meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch
parent0c3b1aa0a5461c9b5f3833feb091f7c8a459ca9b (diff)
downloadopenembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.gz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.bz2
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.xz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.zip
meta-emenlow: Layer for eMenlow-based systems.
This layer provides a kernel suitable for booting on eMenlow-based systems, plus support for Poulsbo graphics. The Poulsbo support includes a kernel patch for the graphics driver, a couple of libraries, the 2D and 3D X drivers, and a properly configured X server. The closed portions of this support are in the 3D driver, xpsb-glx. This package contains the binaries for the libraries that communicate with the kernel driver and a mesa library which uses those libraries. There is a README in meta-emenlow/ describing how to enable this layer. Where possible, the recipes use bitbake's new .bbappend facility in order to avoid copying recipes from meta/. There are checksums and license information for all of the new packages. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch')
-rw-r--r--meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch b/meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch
new file mode 100644
index 000000000..f00c52ca4
--- /dev/null
+++ b/meta-emenlow/packages/libva/libva-0.31.0/320_move_vaPutSurface_flags_def.patch
@@ -0,0 +1,60 @@
+commit c682fb5ebd1964638f90590f66edf49629e7481d
+Author: Gwenole Beauchesne <gbeauchesne@splitted-desktop.com>
+Date: Fri Aug 21 11:34:50 2009 +0000
+
+ Move vaPutSurface() flags to <va/va.h> header.
+
+diff --git a/src/va.h b/src/va.h
+index 0519f6f..6b4bbd4 100755
+--- a/src/va.h
++++ b/src/va.h
+@@ -127,6 +127,22 @@ typedef int VAStatus; /* Return status type from functions */
+ #define VA_STATUS_ERROR_RESOLUTION_NOT_SUPPORTED 0x00000013
+ #define VA_STATUS_ERROR_UNKNOWN 0xFFFFFFFF
+
++/* De-interlacing flags for vaPutSurface() */
++#define VA_FRAME_PICTURE 0x00000000
++#define VA_TOP_FIELD 0x00000001
++#define VA_BOTTOM_FIELD 0x00000002
++
++/*
++ * Clears the drawable with background color.
++ * for hardware overlay based implementation this flag
++ * can be used to turn off the overlay
++ */
++#define VA_CLEAR_DRAWABLE 0x00000008
++
++/* Color space conversion flags for vaPutSurface() */
++#define VA_SRC_BT601 0x00000010
++#define VA_SRC_BT709 0x00000020
++
+ /*
+ * Returns a short english description of error_status
+ */
+diff --git a/src/x11/va_x11.h b/src/x11/va_x11.h
+index 2171ac6..5ab5200 100644
+--- a/src/x11/va_x11.h
++++ b/src/x11/va_x11.h
+@@ -27,22 +27,6 @@ VADisplay vaGetDisplay (
+ * color space conversion and scaling to the destination
+ * rectangle
+ */
+-/* de-interlacing flags for vaPutSurface */
+-#define VA_FRAME_PICTURE 0x00000000
+-#define VA_TOP_FIELD 0x00000001
+-#define VA_BOTTOM_FIELD 0x00000002
+-
+-/*
+- * clears the drawable with background color.
+- * for hardware overlay based implementation this flag
+- * can be used to turn off the overlay
+- */
+-#define VA_CLEAR_DRAWABLE 0x00000008
+-
+-/* color space conversion flags for vaPutSurface */
+-#define VA_SRC_BT601 0x00000010
+-#define VA_SRC_BT709 0x00000020
+-
+ VAStatus vaPutSurface (
+ VADisplay dpy,
+ VASurfaceID surface,