summaryrefslogtreecommitdiff
path: root/meta-emenlow/packages/libva/libva_0.31.0.bb
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-21 17:31:45 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 22:39:43 +0100
commite8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304 (patch)
treec8ed16e490e2e30de292c8a10eedb084d5abdea8 /meta-emenlow/packages/libva/libva_0.31.0.bb
parent0c3b1aa0a5461c9b5f3833feb091f7c8a459ca9b (diff)
downloadopenembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.gz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.bz2
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.xz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.zip
meta-emenlow: Layer for eMenlow-based systems.
This layer provides a kernel suitable for booting on eMenlow-based systems, plus support for Poulsbo graphics. The Poulsbo support includes a kernel patch for the graphics driver, a couple of libraries, the 2D and 3D X drivers, and a properly configured X server. The closed portions of this support are in the 3D driver, xpsb-glx. This package contains the binaries for the libraries that communicate with the kernel driver and a mesa library which uses those libraries. There is a README in meta-emenlow/ describing how to enable this layer. Where possible, the recipes use bitbake's new .bbappend facility in order to avoid copying recipes from meta/. There are checksums and license information for all of the new packages. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/libva/libva_0.31.0.bb')
-rw-r--r--meta-emenlow/packages/libva/libva_0.31.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-emenlow/packages/libva/libva_0.31.0.bb b/meta-emenlow/packages/libva/libva_0.31.0.bb
new file mode 100644
index 000000000..52cd59995
--- /dev/null
+++ b/meta-emenlow/packages/libva/libva_0.31.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Video Acceleration (VA) API for Linux"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e"
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \
+ file://033_g45_add_rgba_subpic.patch;patch=1 \
+ file://034_g45_fix_return_for_unimpl.patch;patch=1 \
+ file://035_g45_add_yv12_image_format.patch;patch=1 \
+ file://036_g45_add_vaGetImage.patch;patch=1 \
+ file://037_g45_add_vaPutImage.patch;patch=1 \
+ file://038_g45_vaPutSurface_cliprects.patch;patch=1 \
+ file://102_attribute_visibility.patch;patch=1 \
+ file://103_fix_vainfo_deps.patch;patch=1 \
+ file://104_fix_libva_pkgconfig_deps.patch;patch=1 \
+ file://105_dont_search_LIBGL_DRIVERS_PATH.patch;patch=1 \
+ file://108_drivers_path.patch;patch=1 \
+ file://203_fix_fglrx_detection.patch;patch=1 \
+ file://204_check_ATIFGLEXTENSION.patch;patch=1 \
+ file://300_sds_version.patch;patch=1 \
+ file://301_vdpau_mpeg4.patch;patch=1 \
+ file://320_move_vaPutSurface_flags_def.patch;patch=1 \
+ file://321_libva_glx.base.patch;patch=1 \
+ file://322_libva_glx.patch;patch=1 \
+ file://390_compat.base.patch;patch=1 \
+ file://391_compat.patch;patch=1 \
+ file://392_compat.dso.patch;patch=1"
+
+export LDFLAGS="-Wl,-z,defs"
+
+EXTRA_OECONF = "--disable-i965-driver"
+
+FILES_${PN} += "${libdir}/va/drivers/*"