summaryrefslogtreecommitdiff
path: root/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-21 17:31:45 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 22:39:43 +0100
commite8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304 (patch)
treec8ed16e490e2e30de292c8a10eedb084d5abdea8 /meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
parent0c3b1aa0a5461c9b5f3833feb091f7c8a459ca9b (diff)
downloadopenembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.gz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.bz2
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.xz
openembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.zip
meta-emenlow: Layer for eMenlow-based systems.
This layer provides a kernel suitable for booting on eMenlow-based systems, plus support for Poulsbo graphics. The Poulsbo support includes a kernel patch for the graphics driver, a couple of libraries, the 2D and 3D X drivers, and a properly configured X server. The closed portions of this support are in the 3D driver, xpsb-glx. This package contains the binaries for the libraries that communicate with the kernel driver and a mesa library which uses those libraries. There is a README in meta-emenlow/ describing how to enable this layer. Where possible, the recipes use bitbake's new .bbappend facility in order to avoid copying recipes from meta/. There are checksums and license information for all of the new packages. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb')
-rw-r--r--meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb b/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
new file mode 100644
index 000000000..fc014fca0
--- /dev/null
+++ b/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "2D graphics driver for Poulsbo"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/xserver-xorg-video-psb_0.36.0-0ubuntu3~1004um9.tar.gz \
+ file://xorg-x11-drv-psb-0.31.0-ignoreacpi.patch;patch=1 \
+ file://xorg-x11-drv-psb-0.31.0-xserver17.patch;patch=1 \
+ file://xserver-xorg-video-psb-0.31.0-assert.patch;patch=1 \
+ file://xserver-xorg-video-psb-0.31.0-comment_unused.patch;patch=1 \
+ file://xserver-xorg-video-psb-0.31.0-greedy.patch;patch=1 \
+ file://xserver-xorg-video-psb-0.31.0-loader.patch;patch=1 \
+ file://stubs.patch;patch=1 \
+ file://01_disable_lid_timer.patch;patch=1 \
+ file://psb_xvtempfix.patch;patch=1 \
+ file://psb_mixed.patch;patch=1 \
+ file://dri-h.patch"
+
+export DRI_CFLAGS="-I${STAGING_INCDIR}/psb -I${STAGING_INCDIR}/psb/drm \
+ -I${STAGING_INCDIR}/X11/dri"
+
+export CFLAGS = "-fvisibility=default"
+export XORG_CFLAGS="-fvisibility=default -I${STAGING_INCDIR}/xorg \
+ -I${STAGING_INCDIR}/pixman-1"
+
+FILES_${PN} += "${libdir}/xorg/modules/drivers/libmm.so \
+ ${libdir}/xorg/modules/drivers/psb_drv.so"
+
+DEPENDS += "virtual/libgl virtual/xserver"