summaryrefslogtreecommitdiff
path: root/meta-extras/packages/python/python-pygtk
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-25 20:33:55 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-25 20:33:55 +0000
commit16e6877c4ce53fd3be88dd77263a03e7d88c3163 (patch)
tree831004ca391e04c8deaace28b15cb602c0848c77 /meta-extras/packages/python/python-pygtk
parent07eeb6a8b6d671db7566f839ab22a26b6f118077 (diff)
downloadopenembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.gz
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.bz2
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.tar.xz
openembedded-core-16e6877c4ce53fd3be88dd77263a03e7d88c3163.zip
python: Promote from meta-extras to meta
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5092 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-pygtk')
-rw-r--r--meta-extras/packages/python/python-pygtk/acinclude.m490
-rw-r--r--meta-extras/packages/python/python-pygtk/fix-gtkunixprint.patch16
-rw-r--r--meta-extras/packages/python/python-pygtk/nodocs.patch13
-rw-r--r--meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch14
-rw-r--r--meta-extras/packages/python/python-pygtk/python-pygtk2/acinclude.m490
5 files changed, 0 insertions, 223 deletions
diff --git a/meta-extras/packages/python/python-pygtk/acinclude.m4 b/meta-extras/packages/python/python-pygtk/acinclude.m4
deleted file mode 100644
index 53518fb2e..000000000
--- a/meta-extras/packages/python/python-pygtk/acinclude.m4
+++ /dev/null
@@ -1,90 +0,0 @@
-## this one is commonly used with AM_PATH_PYTHONDIR ...
-dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
-dnl Check if a module containing a given symbol is visible to python.
-AC_DEFUN(AM_CHECK_PYMOD,
-[AC_REQUIRE([AM_PATH_PYTHON])
-py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
-AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
-AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
-ifelse([$2],[], [prog="
-import sys
-try:
- import $1
-except ImportError:
- sys.exit(1)
-except:
- sys.exit(0)
-sys.exit(0)"], [prog="
-import $1
-$1.$2"])
-if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
- then
- eval "py_cv_mod_$py_mod_var=yes"
- else
- eval "py_cv_mod_$py_mod_var=no"
- fi
-])
-py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
-if test "x$py_val" != xno; then
- AC_MSG_RESULT(yes)
- ifelse([$3], [],, [$3
-])dnl
-else
- AC_MSG_RESULT(no)
- ifelse([$4], [],, [$4
-])dnl
-fi
-])
-
-dnl a macro to check for ability to create python extensions
-dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
-dnl function also defines PYTHON_INCLUDES
-AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
-[AC_REQUIRE([AM_PATH_PYTHON])
-AC_MSG_CHECKING(for headers required to compile python extensions)
-dnl deduce PYTHON_INCLUDES
-AC_ARG_WITH(python-includes,
- [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
-if test x$py_exec_prefix != x; then
-PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-else
-py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
-py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
-if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-fi
-fi
-AC_SUBST(PYTHON_INCLUDES)
-dnl check if the headers exist:
-save_CPPFLAGS="$CPPFLAGS"
-CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
-AC_TRY_CPP([#include <Python.h>],dnl
-[AC_MSG_RESULT(found)
-$1],dnl
-[AC_MSG_RESULT(not found)
-$2])
-CPPFLAGS="$save_CPPFLAGS"
-])
-
-dnl
-dnl JH_ADD_CFLAG(FLAG)
-dnl checks whether the C compiler supports the given flag, and if so, adds
-dnl it to $CFLAGS. If the flag is already present in the list, then the
-dnl check is not performed.
-AC_DEFUN([JH_ADD_CFLAG],
-[
-case " $CFLAGS " in
-*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
- ;;
-*)
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $1"
- AC_MSG_CHECKING([whether [$]CC understands $1])
- AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
- AC_MSG_RESULT($jh_has_option)
- if test $jh_has_option = no; then
- CFLAGS="$save_CFLAGS"
- fi
- ;;
-esac])
diff --git a/meta-extras/packages/python/python-pygtk/fix-gtkunixprint.patch b/meta-extras/packages/python/python-pygtk/fix-gtkunixprint.patch
deleted file mode 100644
index dca19ce5e..000000000
--- a/meta-extras/packages/python/python-pygtk/fix-gtkunixprint.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: pygtk-2.10.0/gtk/gtkunixprint.override
-===================================================================
---- pygtk-2.10.0.orig/gtk/gtkunixprint.override
-+++ pygtk-2.10.0/gtk/gtkunixprint.override
-@@ -105,11 +105,7 @@ _wrap_gtk_print_job_get_surface(PyGObjec
- if (pyg_error_check(&error))
- return NULL;
-
--#if PYCAIRO_VERSION_HEX >= 0x1010600
- return PycairoSurface_FromSurface(surface, NULL);
--#else
-- return PycairoSurface_FromSurface(surface, NULL, NULL);
--#endif
- }
- %%
- override gtk_print_job_send kwargs
diff --git a/meta-extras/packages/python/python-pygtk/nodocs.patch b/meta-extras/packages/python/python-pygtk/nodocs.patch
deleted file mode 100644
index 9b2387e95..000000000
--- a/meta-extras/packages/python/python-pygtk/nodocs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: pygtk-2.10.4/Makefile.am
-===================================================================
---- pygtk-2.10.4.orig/Makefile.am
-+++ pygtk-2.10.4/Makefile.am
-@@ -4,7 +4,7 @@ if BUILD_GTK
- GTK_SUBDIR = gtk
- endif
-
--SUBDIRS = codegen . $(GTK_SUBDIR) examples tests docs
-+SUBDIRS = codegen . $(GTK_SUBDIR) examples tests
-
- PLATFORM_VERSION = 2.0
-
diff --git a/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch b/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch
deleted file mode 100644
index 9340f8244..000000000
--- a/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: pygtk-2.10.4/gtk/__init__.py
-===================================================================
---- pygtk-2.10.4.orig/gtk/__init__.py 2007-11-27 19:27:05.000000000 -0300
-+++ pygtk-2.10.4/gtk/__init__.py 2007-11-27 19:28:22.000000000 -0300
-@@ -78,7 +78,8 @@
-
- keysyms = LazyModule('keysyms', locals())
-
--_init()
-+if not hasattr(sys.modules['__main__'], 'python_launcher_enabled'):
-+ _init()
-
- # CAPI
- _PyGtk_API = _gtk._PyGtk_API
diff --git a/meta-extras/packages/python/python-pygtk/python-pygtk2/acinclude.m4 b/meta-extras/packages/python/python-pygtk/python-pygtk2/acinclude.m4
deleted file mode 100644
index 53518fb2e..000000000
--- a/meta-extras/packages/python/python-pygtk/python-pygtk2/acinclude.m4
+++ /dev/null
@@ -1,90 +0,0 @@
-## this one is commonly used with AM_PATH_PYTHONDIR ...
-dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
-dnl Check if a module containing a given symbol is visible to python.
-AC_DEFUN(AM_CHECK_PYMOD,
-[AC_REQUIRE([AM_PATH_PYTHON])
-py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
-AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
-AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
-ifelse([$2],[], [prog="
-import sys
-try:
- import $1
-except ImportError:
- sys.exit(1)
-except:
- sys.exit(0)
-sys.exit(0)"], [prog="
-import $1
-$1.$2"])
-if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
- then
- eval "py_cv_mod_$py_mod_var=yes"
- else
- eval "py_cv_mod_$py_mod_var=no"
- fi
-])
-py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
-if test "x$py_val" != xno; then
- AC_MSG_RESULT(yes)
- ifelse([$3], [],, [$3
-])dnl
-else
- AC_MSG_RESULT(no)
- ifelse([$4], [],, [$4
-])dnl
-fi
-])
-
-dnl a macro to check for ability to create python extensions
-dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
-dnl function also defines PYTHON_INCLUDES
-AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
-[AC_REQUIRE([AM_PATH_PYTHON])
-AC_MSG_CHECKING(for headers required to compile python extensions)
-dnl deduce PYTHON_INCLUDES
-AC_ARG_WITH(python-includes,
- [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
-if test x$py_exec_prefix != x; then
-PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-else
-py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
-py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
-if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-fi
-fi
-AC_SUBST(PYTHON_INCLUDES)
-dnl check if the headers exist:
-save_CPPFLAGS="$CPPFLAGS"
-CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
-AC_TRY_CPP([#include <Python.h>],dnl
-[AC_MSG_RESULT(found)
-$1],dnl
-[AC_MSG_RESULT(not found)
-$2])
-CPPFLAGS="$save_CPPFLAGS"
-])
-
-dnl
-dnl JH_ADD_CFLAG(FLAG)
-dnl checks whether the C compiler supports the given flag, and if so, adds
-dnl it to $CFLAGS. If the flag is already present in the list, then the
-dnl check is not performed.
-AC_DEFUN([JH_ADD_CFLAG],
-[
-case " $CFLAGS " in
-*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
- ;;
-*)
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $1"
- AC_MSG_CHECKING([whether [$]CC understands $1])
- AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
- AC_MSG_RESULT($jh_has_option)
- if test $jh_has_option = no; then
- CFLAGS="$save_CFLAGS"
- fi
- ;;
-esac])