summaryrefslogtreecommitdiff
path: root/meta-lsb/packages/at/at-3.1.12
diff options
context:
space:
mode:
authorScott Garman <sgarman@zenlinux.com>2010-07-23 12:04:10 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 00:01:28 +0100
commit0d333290a530164a7cbb62b5bc0e848d644069b6 (patch)
treed3cc48765936cb4826df964c231ba940bd09b051 /meta-lsb/packages/at/at-3.1.12
parent6da4a6688cbd90acb949d68247d9ab9c676021cf (diff)
downloadopenembedded-core-0d333290a530164a7cbb62b5bc0e848d644069b6.tar.gz
openembedded-core-0d333290a530164a7cbb62b5bc0e848d644069b6.tar.bz2
openembedded-core-0d333290a530164a7cbb62b5bc0e848d644069b6.tar.xz
openembedded-core-0d333290a530164a7cbb62b5bc0e848d644069b6.zip
at: New recipe additions 3.1.10.2 and 3.1.12
* at 3.1.12 is GPLv3 * at 3.1.10.2 is latest GPLv2 Recipes and patches derived from OpenEmbedded Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta-lsb/packages/at/at-3.1.12')
-rw-r--r--meta-lsb/packages/at/at-3.1.12/configure.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-lsb/packages/at/at-3.1.12/configure.patch b/meta-lsb/packages/at/at-3.1.12/configure.patch
new file mode 100644
index 000000000..6ab528d0b
--- /dev/null
+++ b/meta-lsb/packages/at/at-3.1.12/configure.patch
@@ -0,0 +1,22 @@
+# Fix cross-compilation issues in configure.ac
+# Derived from an OE patch for at-3.1.8
+
+--- at-3.1.12.orig/configure.ac 2009-11-23 07:11:52.000000000 -0800
++++ at-3.1.12/configure.ac 2010-07-20 16:23:14.000000000 -0700
+@@ -38,12 +38,11 @@
+ AC_MSG_RESULT(no)
+ ;;
+ esac
++if [ X"${cross_compiling}" = Xno ]; then
+ AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
+-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
+- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
++AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])], [AC_MSG_RESULT(yes)], [AC_MSG_RESULT(no)
++ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)], [AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
++fi
+
+ AC_MSG_CHECKING(__attribute__((noreturn)))
+ AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],