summaryrefslogtreecommitdiff
path: root/meta-lsb/packages/which
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
commitbb75c1810454a90a070370fee724da156acb888f (patch)
treeb8ae6e5c6ec1ad15108e20fdd52976ff93705d58 /meta-lsb/packages/which
parent5abb132fec3e084bcefb4b6197b4806f6b05f515 (diff)
downloadopenembedded-core-bb75c1810454a90a070370fee724da156acb888f.tar.gz
openembedded-core-bb75c1810454a90a070370fee724da156acb888f.tar.bz2
openembedded-core-bb75c1810454a90a070370fee724da156acb888f.tar.xz
openembedded-core-bb75c1810454a90a070370fee724da156acb888f.zip
Move byacc, which, libconvert-asn1-perl and libtimedate-perl to meta-lsb
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-lsb/packages/which')
-rw-r--r--meta-lsb/packages/which/which-2.20/remove-declaration.patch16
-rw-r--r--meta-lsb/packages/which/which_2.20.bb35
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-lsb/packages/which/which-2.20/remove-declaration.patch b/meta-lsb/packages/which/which-2.20/remove-declaration.patch
new file mode 100644
index 000000000..09b81439b
--- /dev/null
+++ b/meta-lsb/packages/which/which-2.20/remove-declaration.patch
@@ -0,0 +1,16 @@
+Remove the declaration of group_member since it has already been
+declared in unistd.h
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN which-2.20-orig/bash.c which-2.20/bash.c
+--- which-2.20-orig/bash.c 2010-08-03 12:59:08.897088878 +0800
++++ which-2.20/bash.c 2010-08-03 13:17:23.406097212 +0800
+@@ -46,7 +46,6 @@
+ * - changed all occurences of 'gid_t' into 'GID_T'.
+ * - exported functions needed in which.c
+ */
+-static int group_member (GID_T gid);
+ static char* extract_colon_unit (char const* string, int* p_index);
+
+ /*===========================================================================
diff --git a/meta-lsb/packages/which/which_2.20.bb b/meta-lsb/packages/which/which_2.20.bb
new file mode 100644
index 000000000..b7730de3b
--- /dev/null
+++ b/meta-lsb/packages/which/which_2.20.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "which - shows the full path of (shell) commands."
+SECTION = "libs"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
+ file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
+HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
+DEPENDS = "cwautomacros-native"
+
+inherit autotools
+
+PR = "r0"
+
+SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
+ file://remove-declaration.patch"
+
+do_configure_prepend() {
+ sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
+}
+
+do_install() {
+ autotools_do_install
+ mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
+}
+
+pkg_postinst_${PN} () {
+ if [ "${PN}" = "${BPN}" ] ; then
+ update-alternatives --install ${bindir}/which which which.${PN} 100
+ fi
+}
+
+pkg_prerm_${PN} () {
+ if [ "${PN}" = "${BPN}" ] ; then
+ update-alternatives --remove which which.${PN}
+ fi
+}