summaryrefslogtreecommitdiff
path: root/meta-lsb/packages/xinetd/xinetd_2.3.14.bb
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-07-28 11:34:32 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-19 13:06:56 +0100
commit23552a40fcc37f58cb4d6ab6a864dfaf9154267a (patch)
tree8edfa39cbdad41324e9a84ba3ce4bd29082ddd8a /meta-lsb/packages/xinetd/xinetd_2.3.14.bb
parent90e8bc75e3d32029bc740ce5ca3db1b45c8a7240 (diff)
downloadopenembedded-core-23552a40fcc37f58cb4d6ab6a864dfaf9154267a.tar.gz
openembedded-core-23552a40fcc37f58cb4d6ab6a864dfaf9154267a.tar.bz2
openembedded-core-23552a40fcc37f58cb4d6ab6a864dfaf9154267a.tar.xz
openembedded-core-23552a40fcc37f58cb4d6ab6a864dfaf9154267a.zip
xinetd: add xinetd
xinetd is highly configurable, modular and secure inetd. this commmit add xinetd 2.3.14. The receipts is borrowed from OE, with following changes: - upgrade the version from 2.3.13 to 2.3.14 - pick three patches from debian xinetd 2.3.14-7. Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta-lsb/packages/xinetd/xinetd_2.3.14.bb')
-rw-r--r--meta-lsb/packages/xinetd/xinetd_2.3.14.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-lsb/packages/xinetd/xinetd_2.3.14.bb b/meta-lsb/packages/xinetd/xinetd_2.3.14.bb
new file mode 100644
index 000000000..02e68f2d3
--- /dev/null
+++ b/meta-lsb/packages/xinetd/xinetd_2.3.14.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Highly configurable, modular and secure inetd"
+HOMEPAGE = "http://www.xinetd.org"
+
+# xinetd is a BSD-like license
+LICENSE = "xinetd"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
+
+DEPENDS = ""
+PR ="r0"
+
+SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
+ file://xinetd.init \
+ file://xinetd.conf \
+ file://Various-fixes-from-the-previous-maintainer.patch \
+ file://Disable-services-from-inetd.conf-if-a-service-with-t.patch \
+ file://xinetd-should-be-able-to-listen-on-IPv6-even-in-ine.patch \
+ "
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "xinetd"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OECONF="--disable-nls"
+
+do_configure() {
+ # Looks like configure.in is broken, so we are skipping
+ # rebuilding configure and are just using the shipped one
+ oe_runconf
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ # Same here, the Makefile does some really stupid things,
+ # but since we only want two files why not override
+ # do_install from autotools and doing it ourselfs?
+ install -d "${D}/usr/sbin"
+ install -d "${D}/etc/init.d"
+ install -d "${D}/etc/xinetd.d"
+ install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
+ install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
+ install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
+ install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
+}
+
+CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"