summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-04-21 17:33:19 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-04-21 17:33:19 +0100
commitf114fd24924540dd5dfbd7483824d6b30c246bc6 (patch)
tree42936b142dd203c63f5133c95163400641a7ffdf /meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
parente23c356916550cafbe3a93b28b76e762cb5043b7 (diff)
downloadopenembedded-core-f114fd24924540dd5dfbd7483824d6b30c246bc6.tar.gz
openembedded-core-f114fd24924540dd5dfbd7483824d6b30c246bc6.tar.bz2
openembedded-core-f114fd24924540dd5dfbd7483824d6b30c246bc6.tar.xz
openembedded-core-f114fd24924540dd5dfbd7483824d6b30c246bc6.zip
linux-moblin: Switch to 2.6.29.1
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch')
-rw-r--r--meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch b/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
new file mode 100644
index 000000000..eda77564c
--- /dev/null
+++ b/meta-moblin/packages/linux/linux-moblin-2.6.29.1/linux-2.6.29-flip-ide-net.patch
@@ -0,0 +1,40 @@
+From: Arjan van de Ven <arjan@linux.intel.com>
+Date: Mon, 26 Jan 2009 18:58:11 -0800
+Subject: [PATCH] ide/net: flip the order of SATA and network init
+
+this patch flips the order in which sata and network drivers are initialized.
+
+SATA probing takes quite a bit of time, and with the asynchronous infrastructure
+other drivers that run after it can execute in parallel. Network drivers do tend
+to take some real time talking to the hardware, so running these later is
+a good thing (the sata probe then runs concurrent)
+
+This saves about 15% of my kernels boot time.
+
+Signed-off-by: Arjan van de Ven <arjan@linux.intel.com>
+---
+ drivers/Makefile | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/Makefile b/drivers/Makefile
+index c1bf417..2618a61 100644
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -36,13 +36,14 @@
+ obj-$(CONFIG_FB_INTEL) += video/intelfb/
+ obj-y += serial/
+ obj-$(CONFIG_PARPORT) += parport/
+-obj-y += base/ block/ misc/ mfd/ net/ media/
++obj-y += base/ block/ misc/ mfd/ media/
+ obj-$(CONFIG_NUBUS) += nubus/
+-obj-$(CONFIG_ATM) += atm/
+ obj-y += macintosh/
+ obj-$(CONFIG_IDE) += ide/
+ obj-$(CONFIG_SCSI) += scsi/
+ obj-$(CONFIG_ATA) += ata/
++obj-y += net/
++obj-$(CONFIG_ATM) += atm/
+ obj-$(CONFIG_FUSION) += message/
+ obj-$(CONFIG_FIREWIRE) += firewire/
+ obj-y += ieee1394/
+