summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-19 18:06:20 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-19 18:06:20 +0100
commitcd60a7eb241e7e658cfa88043ca0049845ebdecd (patch)
tree66ea5034858475aed63a906c5184ac20d6b30781 /meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
parent19e1d23dd1c46b11d929d8803f24121b7b8447d3 (diff)
downloadopenembedded-core-cd60a7eb241e7e658cfa88043ca0049845ebdecd.tar.gz
openembedded-core-cd60a7eb241e7e658cfa88043ca0049845ebdecd.tar.bz2
openembedded-core-cd60a7eb241e7e658cfa88043ca0049845ebdecd.tar.xz
openembedded-core-cd60a7eb241e7e658cfa88043ca0049845ebdecd.zip
meta-moblin: Add recipes for most moblin beta components
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb')
-rw-r--r--meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
new file mode 100644
index 000000000..37d5b2158
--- /dev/null
+++ b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "A Moblin specific plugin for the Mutter composite window manager"
+SECTION = "x11/wm"
+LICENSE = "GPLv3"
+DEPENDS = "nbtk mutter gnome-menus mojito libjana anerley clutter-mozembed"
+PV = "2.25.2+git${SRCPV}"
+PR = "r3"
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
+ file://startup-notify.patch;patch=1 \
+ file://background-tile.png"
+
+FILES_${PN} += "${libdir}/metacity/plugins/clutter/*.so* ${datadir}/mutter-moblin-netbook-plugin"
+FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
+
+S = "${WORKDIR}/git"
+
+ASNEEDED = ""
+
+EXTRA_OECONF = "--enable-ahoghill --enable-netpanel --enable-people"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ rm -f ${S}/build/autotools/gtk-doc.m4
+ cp ${WORKDIR}/background-tile.png ${S}/data/theme/panel/
+}
+
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[moblin-netbook]'
+}