summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/packagekit/files
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-29 11:36:06 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-29 11:36:06 +0000
commit6ca0e13033085542332ad812bc62ae9243b8688f (patch)
treed214645a0c190ecb5c64a1e1253affa44e802a8a /meta-moblin/packages/packagekit/files
parentdb39d570e6a391a892fc0616e4e53168bc0d5522 (diff)
downloadopenembedded-core-6ca0e13033085542332ad812bc62ae9243b8688f.tar.gz
openembedded-core-6ca0e13033085542332ad812bc62ae9243b8688f.tar.bz2
openembedded-core-6ca0e13033085542332ad812bc62ae9243b8688f.tar.xz
openembedded-core-6ca0e13033085542332ad812bc62ae9243b8688f.zip
packagekit: 0.4.9 -> 0.6.0 (with fixes for opkg)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/packagekit/files')
-rw-r--r--meta-moblin/packages/packagekit/files/no_validate.patch21
-rw-r--r--meta-moblin/packages/packagekit/files/opkg-fix-declarations.diff22
2 files changed, 0 insertions, 43 deletions
diff --git a/meta-moblin/packages/packagekit/files/no_validate.patch b/meta-moblin/packages/packagekit/files/no_validate.patch
deleted file mode 100644
index f987b567d..000000000
--- a/meta-moblin/packages/packagekit/files/no_validate.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: PackageKit-0.3.8/configure.ac
-===================================================================
---- PackageKit-0.3.8.orig/configure.ac 2008-11-04 21:37:17.000000000 +0000
-+++ PackageKit-0.3.8/configure.ac 2008-11-04 21:37:57.000000000 +0000
-@@ -451,11 +451,11 @@
- polkit-grant >= $POLKIT_GRANT_REQUIRED)
- AC_SUBST(POLKIT_CFLAGS)
- AC_SUBST(POLKIT_LIBS)
-- AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
-- [polkit-policy-file-validate], [polkit-policy-file-validate])
-- if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
-- AC_MSG_ERROR([polkit-policy-file-validate not found])
-- fi
-+ #AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
-+ # [polkit-policy-file-validate], [polkit-policy-file-validate])
-+ #if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
-+ # AC_MSG_ERROR([polkit-policy-file-validate not found])
-+ #fi
- AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
- elif test x$with_security_framework = xdummy; then
- AC_DEFINE(USE_SECURITY_DUMMY, 1, [if we should use a dummy security framework])
diff --git a/meta-moblin/packages/packagekit/files/opkg-fix-declarations.diff b/meta-moblin/packages/packagekit/files/opkg-fix-declarations.diff
deleted file mode 100644
index 8c86fabe4..000000000
--- a/meta-moblin/packages/packagekit/files/opkg-fix-declarations.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-http://bugs.freedesktop.org/show_bug.cgi?id=20922
-
---- /tmp/pk-backend-opkg.c 2009-03-28 12:32:28.000000000 +0100
-+++ PackageKit-0.4.5/backends/opkg/pk-backend-opkg.c 2009-03-28 12:48:04.000000000 +0100
-@@ -47,7 +47,7 @@
- } SearchParams;
-
- static void
--opkg_unknown_error (PkBackend *backend, gint error_code, gchar *failed_cmd)
-+opkg_unknown_error (PkBackend *backend, gint error_code, const gchar *failed_cmd)
- {
- gchar *msg;
-
-@@ -105,7 +105,7 @@
- *
- * returns true if the tag is present
- */
--gboolean
-+static gboolean
- opkg_check_tag (opkg_package_t *pkg, gchar *tag)
- {
- if (pkg->tags && tag)