summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/samba/samba_3.3.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-16 09:56:39 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-16 09:56:39 +0100
commit6cce850bcb3e87ef04ed9bacd52bf1bf63e557d8 (patch)
tree81ed760a1be1be66517241aed227b0f5f31ae6a0 /meta-moblin/packages/samba/samba_3.3.0.bb
parentcd5fa1ee4e3f8fdeb620487d8dc5e4c8ca9da15f (diff)
downloadopenembedded-core-6cce850bcb3e87ef04ed9bacd52bf1bf63e557d8.tar.gz
openembedded-core-6cce850bcb3e87ef04ed9bacd52bf1bf63e557d8.tar.bz2
openembedded-core-6cce850bcb3e87ef04ed9bacd52bf1bf63e557d8.tar.xz
openembedded-core-6cce850bcb3e87ef04ed9bacd52bf1bf63e557d8.zip
samba: Add from OE but split libtdb out into its own package
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/samba/samba_3.3.0.bb')
-rw-r--r--meta-moblin/packages/samba/samba_3.3.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-moblin/packages/samba/samba_3.3.0.bb b/meta-moblin/packages/samba/samba_3.3.0.bb
new file mode 100644
index 000000000..c561d9552
--- /dev/null
+++ b/meta-moblin/packages/samba/samba_3.3.0.bb
@@ -0,0 +1,35 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://configure-3.3.0.patch;patch=1 \
+ file://config-h.patch;patch=1 \
+ file://mtab.patch;patch=1 \
+ "
+
+PR = "r2"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ "
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}