summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/xorg-xserver
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:15:49 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:15:49 +0000
commitc8a24cd00235a4ccb501e2cdea606730e166c572 (patch)
tree02d76961863352ce43bbee08c6779ed825f4e8fd /meta-moblin/packages/xorg-xserver
parent459a7f4a342bd9c74e2bc812cd1e6601a8095264 (diff)
downloadopenembedded-core-c8a24cd00235a4ccb501e2cdea606730e166c572.tar.gz
openembedded-core-c8a24cd00235a4ccb501e2cdea606730e166c572.tar.bz2
openembedded-core-c8a24cd00235a4ccb501e2cdea606730e166c572.tar.xz
openembedded-core-c8a24cd00235a4ccb501e2cdea606730e166c572.zip
meta-moblin: Add initial menlow support
Diffstat (limited to 'meta-moblin/packages/xorg-xserver')
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc45
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch13
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch50
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch30
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf87
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb7
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc37
7 files changed, 269 insertions, 0 deletions
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc b/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc
new file mode 100644
index 000000000..d31e97a0e
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "The X.Org X server"
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/base"
+LICENSE = "MIT-X"
+
+# xf86-*-* packages depend on an X server built with the xfree86 DDX
+# so we have a virtual to represent that:
+PROVIDES = "virtual/xserver-xf86"
+
+# Other packages tend to just care that there is *an* X server:
+PROVIDES += "virtual/xserver"
+
+XORG_PN = "xorg-server"
+SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
+ file://xorg.conf"
+
+S = "${WORKDIR}/${XORG_PN}-${PV}"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "${PN}-utils"
+
+FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
+FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so ${libdir}/xorg/modules/*/*.so ${libdir}/xorg/modules/*/*/*.so /etc/X11 "
+FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
+
+FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
+ ${libdir}/xorg/modules/*/.debug \
+ ${libdir}/xorg/modules/*/*/.debug \
+ "
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
+SRC_URI += "file://macro_tweak.patch;patch=1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+ ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
+}
+
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch
new file mode 100644
index 000000000..a62a767f2
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch
@@ -0,0 +1,13 @@
+Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am
+===================================================================
+--- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am 2007-08-23 21:04:53.000000000 +0200
++++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am 2008-03-13 18:27:23.000000000 +0100
+@@ -41,7 +41,7 @@
+
+ AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES)
+
+-INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack
++INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS)
+
+ # FIXME: These need to be added to the build
+ LNX_EXTRA_SRCS = \
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch
new file mode 100644
index 000000000..db29da93c
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch
@@ -0,0 +1,50 @@
+Index: xorg-server-1.5.0/hw/xfree86/dri/dri.c
+===================================================================
+--- xorg-server-1.5.0.orig/hw/xfree86/dri/dri.c 2008-09-24 17:43:04.000000000 +0100
++++ xorg-server-1.5.0/hw/xfree86/dri/dri.c 2008-09-24 17:46:38.000000000 +0100
+@@ -73,10 +73,6 @@
+
+ #define PCI_BUS_NO_DOMAIN(bus) ((bus) & 0xffu)
+
+-#if !defined(PANORAMIX)
+-extern Bool noPanoramiXExtension;
+-#endif
+-
+ static int DRIEntPrivIndex = -1;
+ static DevPrivateKey DRIScreenPrivKey = &DRIScreenPrivKey;
+ static DevPrivateKey DRIWindowPrivKey = &DRIWindowPrivKey;
+@@ -307,7 +303,6 @@
+ drm_context_t * reserved;
+ int reserved_count;
+ int i;
+- Bool xineramaInCore = FALSE;
+ DRIEntPrivPtr pDRIEntPriv;
+ ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
+ DRIContextFlags flags = 0;
+@@ -320,20 +315,13 @@
+ return FALSE;
+ }
+
+- /*
+- * If Xinerama is on, don't allow DRI to initialise. It won't be usable
+- * anyway.
+- */
+- if (xf86LoaderCheckSymbol("noPanoramiXExtension"))
+- xineramaInCore = TRUE;
+-
+- if (xineramaInCore) {
+- if (!noPanoramiXExtension) {
+- DRIDrvMsg(pScreen->myNum, X_WARNING,
+- "Direct rendering is not supported when Xinerama is enabled\n");
+- return FALSE;
+- }
++#if defined(PANORAMIX)
++ if (!noPanoramiXExtension) {
++ DRIDrvMsg(pScreen->myNum, X_WARNING,
++ "Direct rendering is not supported when Xinerama is enabled\n");
++ return FALSE;
+ }
++#endif
+
+ if (!DRIOpenDRMMaster(pScrn, pDRIInfo->SAREASize,
+ pDRIInfo->busIdString,
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch
new file mode 100644
index 000000000..f2ba37fbb
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch
@@ -0,0 +1,30 @@
+Index: xorg-server-1.4/xorg-server.m4
+===================================================================
+--- xorg-server-1.4.orig/xorg-server.m4 2007-08-23 20:04:55.000000000 +0100
++++ xorg-server-1.4/xorg-server.m4 2008-12-26 23:59:53.000000000 +0000
+@@ -28,9 +28,12 @@
+ # Checks for the $1 define in xorg-server.h (from the sdk). If it
+ # is defined, then add $1 to $REQUIRED_MODULES.
+
++m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
++
+ AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
++ PKG_PROG_PKG_CONFIG
+ SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`"
++ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`pkg-config --variable=sdkdir xorg-server`"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include "xorg-server.h"
+ #if !defined $1
+Index: xorg-server-1.4/xorg-server.pc.in
+===================================================================
+--- xorg-server-1.4.orig/xorg-server.pc.in 2008-12-27 00:07:37.000000000 +0000
++++ xorg-server-1.4/xorg-server.pc.in 2008-12-27 00:08:39.000000000 +0000
+@@ -8,5 +8,6 @@
+ Name: xorg-server
+ Description: Modular X.Org X Server
+ Version: @PACKAGE_VERSION@
+-Cflags: -I${sdkdir} @PIXMAN_CFLAGS@
++Requires: pixman-1
++Cflags: -I${sdkdir}
+ Libs: -L${libdir}
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf
new file mode 100644
index 000000000..6a9953cb6
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf
@@ -0,0 +1,87 @@
+
+Section "Files"
+EndSection
+
+#Section "InputDevice"
+# Identifier "Generic Keyboard"
+# Driver "kbd"
+# Option "CoreKeyboard"
+# Option "XkbRules" "xorg"
+# Option "XkbModel" "pc105"
+# Option "XkbLayout" "us"
+#EndSection
+#
+#Section "InputDevice"
+# Identifier "Configured Mouse"
+# Driver "mouse"
+# Option "CorePointer"
+# Option "Device" "/dev/input/mice"
+# Option "Protocol" "ImPS/2"
+# Option "ZAxisMapping" "4 5"
+# Option "Emulate3Buttons" "true"
+#EndSection
+
+#Section "InputDevice"
+# Identifier "Synaptics Touchpad"
+# Driver "synaptics"
+# Option "SendCoreEvents" "true"
+# Option "Device" "/dev/psaux"
+# Option "Protocol" "auto-dev"
+# Option "HorizEdgeScroll" "0"
+#EndSection
+
+#Section "InputDevice"
+# Driver "wacom"
+# Identifier "stylus"
+# Option "Device" "/dev/input/wacom"
+# Option "Type" "stylus"
+# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+#EndSection
+
+#Section "InputDevice"
+# Driver "wacom"
+# Identifier "eraser"
+# Option "Device" "/dev/input/wacom"
+# Option "Type" "eraser"
+# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+#EndSection
+
+#Section "InputDevice"
+# Driver "wacom"
+# Identifier "cursor"
+# Option "Device" "/dev/input/wacom"
+# Option "Type" "cursor"
+# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+#EndSection
+
+Section "Device"
+ Identifier "PSB Graphics Controller"
+ Driver "psb"
+# BusID "PCI:0:2:0"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "PSB Graphics Controller"
+ Monitor "Generic Monitor"
+ DefaultDepth 24
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+# InputDevice "Generic Keyboard"
+# InputDevice "Configured Mouse"
+
+# Uncomment if you have a wacom tablet
+# InputDevice "stylus" "SendCoreEvents"
+# InputDevice "cursor" "SendCoreEvents"
+# InputDevice "eraser" "SendCoreEvents"
+# InputDevice "Synaptics Touchpad"
+EndSection
+
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb
new file mode 100644
index 000000000..f079a9fce
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb
@@ -0,0 +1,7 @@
+require xserver-xf86-lite.inc
+
+PR = "r4"
+
+SRC_URI += "file://drmfix.patch;patch=1 \
+ file://libdri-xinerama-symbol.patch;patch=1 "
+
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc
new file mode 100644
index 000000000..f0812215b
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc
@@ -0,0 +1,37 @@
+require xserver-xf86-common.inc
+
+PROVIDES += "xserver-xf86-lite"
+
+PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86rushproto xf86vidmodeproto xf86bigfontproto compositeproto recordproto resourceproto videoproto scrnsaverproto evieext trapproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto"
+
+LIB_DEPS = "mesa pixman libxfont xtrans libxau libxext libxdmcp libxt libdrm-psb libxkbfile libpciaccess openssl"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+RDEPENDS = "hal xorg-minimal-fonts"
+
+FILES_${PN} += "${bindir}/Xorg "
+
+EXTRA_OECONF += "--disable-acfb \
+ --enable-aiglx=yes \
+ --enable-dri=yes \
+ --enable-glx=yes \
+ --enable-glx-tls=yes \
+ --disable-ccfb \
+ --disable-mcfb \
+ --disable-dga \
+ --disable-xinerama \
+ --disable-xf86misc \
+ --disable-xorgcfg \
+ --disable-record \
+ --disable-dmx \
+ --disable-xnest \
+ --disable-xvfb \
+ --enable-composite \
+ --sysconfdir=/etc/X11 \
+ --localstatedir=/var \
+ --with-pic \
+ --with-int10=x86emu \
+ --with-fontdir=/usr/share/fonts/X11 \
+ --with-xkb-output=/var/lib/xkb \
+ ac_cv_file__usr_share_sgml_X11_defs_ent=no"