summaryrefslogtreecommitdiff
path: root/meta-moblin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-13 14:47:46 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-13 14:47:46 +0100
commit5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33 (patch)
tree49768aabc3f85f642febf08d1ce2922caa7ef9fe /meta-moblin
parent5a5fdd72bc1e3aac12e812f3f23a4ad46b0729bb (diff)
downloadopenembedded-core-5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33.tar.gz
openembedded-core-5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33.tar.bz2
openembedded-core-5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33.tar.xz
openembedded-core-5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33.zip
moblin-web-browser: Update patch against master
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch28
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb2
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
index e920b50ee..73abea2c1 100644
--- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
@@ -1,26 +1,26 @@
Index: git/configure.ac
===================================================================
---- git.orig/configure.ac 2009-06-23 17:46:31.000000000 +0100
-+++ git/configure.ac 2009-06-23 17:46:48.000000000 +0100
-@@ -44,6 +44,13 @@
- MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul`""
- AC_SUBST([MOZIDLDIR])
+--- git.orig/configure.ac 2009-08-12 15:12:47.000000000 +0100
++++ git/configure.ac 2009-08-12 15:13:47.000000000 +0100
+@@ -54,6 +54,13 @@
+ PKG_CHECK_MODULES(CLUTTER_MOZEMBED, clutter-mozembed-0.10)
+ PKG_CHECK_MODULES(GTK, gtk+-2.0)
+IDLPREFIX=
+AC_ARG_WITH(idl-prefix, AC_HELP_STRING([--with-idl-prefix=DIR],[prefix to add to access to the idl files]), with_idl_prefix=${withval})
+if test x"${with_idl_prefix}" != x ; then
-+ IDLPREFIX=${with_idl_prefix}
++ IDLPREFIX=${with_idl_prefix}
+fi
+AC_SUBST([IDLPREFIX])
+
- AC_PATH_PROG(DBUSBINDINGTOOL, dbus-binding-tool)
-
- AC_OUTPUT([
+ if test "x$build_browser" = "xyes"; then
+ PKG_CHECK_MODULES(MWB,
+ clutter-1.0
Index: git/libmwbpages/Makefile.am
===================================================================
---- git.orig/libmwbpages/Makefile.am 2009-06-23 17:46:31.000000000 +0100
-+++ git/libmwbpages/Makefile.am 2009-06-23 17:47:46.000000000 +0100
-@@ -27,10 +27,10 @@
+--- git.orig/libmwbpages/Makefile.am 2009-08-12 15:12:47.000000000 +0100
++++ git/libmwbpages/Makefile.am 2009-08-12 15:12:47.000000000 +0100
+@@ -31,10 +31,10 @@
mwb-gettext.lo : MwbIGettext.h
.idl.h :
@@ -31,5 +31,5 @@ Index: git/libmwbpages/Makefile.am
- $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $<
+ xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $<
- dist_xpt_DATA = MwbIStartPage.xpt MwbIGettext.xpt
- xptdir = $(MOZHOME)/components
+ dist_xpt_DATA = MwbISettings.xpt MwbIStartPage.xpt MwbIGettext.xpt
+ xptdir = $(pkgdatadir)/components
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
index 5e42fc5a5..09dd21a4f 100644
--- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
@@ -4,7 +4,7 @@ SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
file://xpidl.patch;patch=1;notrev=b55d523da7681febfabf9fc40dcd6fcee982b079"
LICENSE = "LGPLv2.1"
PV = "0.0+git${SRCPV}"
-PR = "r5"
+PR = "r6"
DEPENDS = "clutter-1.0 clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless"