summaryrefslogtreecommitdiff
path: root/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-19 15:31:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:16:58 +0100
commit6e9e19230ee731856639f71c5adfb01a92f620d8 (patch)
treee49c91850dddd977630fff4e6469e41aed7d112d /meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
parent4fb6723ab1ee14cf539f0ef2df63a3ee1b978de6 (diff)
downloadopenembedded-core-6e9e19230ee731856639f71c5adfb01a92f620d8.tar.gz
openembedded-core-6e9e19230ee731856639f71c5adfb01a92f620d8.tar.bz2
openembedded-core-6e9e19230ee731856639f71c5adfb01a92f620d8.tar.xz
openembedded-core-6e9e19230ee731856639f71c5adfb01a92f620d8.zip
meta-rt: refresh linux-yocto-rt recipe
Rename the recipe to match the linux-yocto recipe renames using the kernel version in the PV portion of the filename. Add the SRCREVs to the recipe as was done with the core linux-yocto recipes. Add qemux86 as it is also present in the linux-yocto-2.6.34.git repository. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb')
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb b/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
new file mode 100644
index 000000000..01a6761f7
--- /dev/null
+++ b/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
@@ -0,0 +1,44 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+KMACHINE_qemux86 = "common_pc"
+KMACHINE_qemux86-64 = "common_pc_64"
+KMACHINE_atom-pc = "atom-pc"
+
+LINUX_VERSION ?= "2.6.34"
+LINUX_KERNEL_TYPE = "preempt_rt"
+LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
+
+KMETA = wrs_meta
+KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
+
+SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749"
+SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
+SRCREV_machine_atom-pc = "269d71029adcf4d1dbf8441f091d824478d8c87d"
+SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
+
+PR = "r2"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+SRCREV_FORMAT = "meta_machine"
+
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|atom-pc)"
+
+# this performs a fixup on the SRCREV for new/undefined BSPs
+python __anonymous () {
+ import bb, re, string
+
+ kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
+ bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
+}
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
+
+# Functionality flags
+KERNEL_REVISION_CHECKING ?= "t"
+KERNEL_FEATURES=features/netfilter
+
+# extra tasks
+addtask kernel_link_vmlinux after do_compile before do_install
+addtask validate_branches before do_patch after do_kernel_checkout
+
+require recipes-kernel/linux/linux-tools.inc