summaryrefslogtreecommitdiff
path: root/meta-rt/recipes-tests/rt-tests
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-20 09:08:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:16:58 +0100
commit3b2fb9c103c126aff1370f4b98a91649aa70e36b (patch)
tree07a597f45d513f059186f2b06ad33c1c9e816a60 /meta-rt/recipes-tests/rt-tests
parent378368306435fda58cea8105670725feebfe6359 (diff)
downloadopenembedded-core-3b2fb9c103c126aff1370f4b98a91649aa70e36b.tar.gz
openembedded-core-3b2fb9c103c126aff1370f4b98a91649aa70e36b.tar.bz2
openembedded-core-3b2fb9c103c126aff1370f4b98a91649aa70e36b.tar.xz
openembedded-core-3b2fb9c103c126aff1370f4b98a91649aa70e36b.zip
meta-rt: canonicalize directory structure
Use the more standard recipes-*/*/*.bb layout. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-rt/recipes-tests/rt-tests')
-rw-r--r--meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb b/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb
new file mode 100644
index 000000000..6334bcdee
--- /dev/null
+++ b/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Real-Time preemption testcases"
+HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
+SECTION = "tests"
+DEPENDS = "linux-libc-headers eglibc"
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
+ file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
+SRCREV = v0.73
+PV = "git${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnull"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
+ INCLUDEDIR=${includedir}
+}