summaryrefslogtreecommitdiff
path: root/meta/conf/machine/include
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-26 22:22:44 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-26 22:22:44 +0000
commit4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5 (patch)
treef705b0e1e1ea9aa10e4786212eed4a7685362e43 /meta/conf/machine/include
parent36a7962e7428a79c5bde3f3b0fd36ce3ed19b439 (diff)
downloadopenembedded-core-4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5.tar.gz
openembedded-core-4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5.tar.bz2
openembedded-core-4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5.tar.xz
openembedded-core-4952c7e0fede3efbaf5bb9b1e153daa5071ef6a5.zip
Totally rework task handling for machine/distro specific features. Create task-base.bb to handle this and update machine/distro files accordingly. MACHINE_FEATURES and DISTRO_FEATURES together combine to configure the machine specific task-base and other specific tasks can easily be created (task-base-oh-minimal is an exmaple)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@562 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/conf/machine/include')
-rw-r--r--meta/conf/machine/include/handheld-common.conf23
-rw-r--r--meta/conf/machine/include/zaurus-clamshell-2.6.conf42
2 files changed, 7 insertions, 58 deletions
diff --git a/meta/conf/machine/include/handheld-common.conf b/meta/conf/machine/include/handheld-common.conf
deleted file mode 100644
index f8767d2dd..000000000
--- a/meta/conf/machine/include/handheld-common.conf
+++ /dev/null
@@ -1,23 +0,0 @@
-HANDHELD_MODULES = "ipv6 \
-ipsec \
-nvrd \
-mip6-mn \
-tun \
-ide-cs ide-disk ide-probe-mod \
-loop \
-vfat ext2 \
-sunrpc nfs \
-btuart-cs dtl1-cs bt3c-cs rfcomm bnep l2cap sco hci_uart hidp \
-pcnet-cs serial-cs airo-cs \
-af_packet \
-ppp-async ppp-deflate ppp-mppe \
-ip-gre ip-tables ipip \
-irda irlan irnet irport irtty ircomm-tty \
-input uinput \
-"
-
-# Configuration bits for "generic handheld"
-BOOTSTRAP_EXTRA_RDEPENDS += "${PCMCIA_MANAGER} apm apmd network-suspend-scripts"
-BOOTSTRAP_EXTRA_RRECOMMENDS += "ppp wireless-tools irda-utils openswan wpa-supplicant-nossl lrzsz ppp-dialin ${@linux_module_packages('${HANDHELD_MODULES}', d)}"
-
-INHERIT += "linux_modules"
diff --git a/meta/conf/machine/include/zaurus-clamshell-2.6.conf b/meta/conf/machine/include/zaurus-clamshell-2.6.conf
index 3c19ef3da..fa2adda6f 100644
--- a/meta/conf/machine/include/zaurus-clamshell-2.6.conf
+++ b/meta/conf/machine/include/zaurus-clamshell-2.6.conf
@@ -6,41 +6,13 @@ PREFERRED_VERSION_wpa_supplicant = "0.4.7"
PCMCIA_MANAGER ?= "pcmciautils"
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel udev sysfsutils spectrum-fw \
-${PCMCIA_MANAGER} apm wireless-tools irda-utils udev-utils keymaps hostap-utils prism3-firmware prism3-support \
-ppp ppp-dialin openswan wpa-supplicant-nossl alsa-utils-alsactl alsa-utils-alsamixer module-init-tools alsa-conf zaurusd"
+MACHINE_FEATURES = "kernel26 apm alsa pcmcia bluetooth irda usbgadget"
+MACHINE_FEATURES_akita = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost"
+MACHINE_FEATURES_spitz = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost ext2"
-# Ethernet modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-pcnet-cs"
-# NFS Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-nfs kernel-module-lockd kernel-module-sunrpc"
-# Crypto Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-des kernel-module-md5"
-# SMB and CRAMFS
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-smbfs kernel-module-cramfs"
-# Serial Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-8250 kernel-module-serial-cs"
-# Bluetooth Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-bluetooth kernel-module-l2cap kernel-module-rfcomm kernel-module-hci-vhci \
- kernel-module-bnep kernel-module-hidp kernel-module-hci-uart kernel-module-sco \
- kernel-module-bt3c-cs kernel-module-bluecard-cs kernel-module-btuart-cs kernel-module-dtl1-cs"
-# Infrared Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-pxaficp-ir kernel-module-irda kernel-module-ircomm \
- kernel-module-ircomm-tty kernel-module-irlan kernel-module-irnet kernel-module-ir-usb"
-# USB Gadget Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-gadgetfs kernel-module-g-file-storage \
- kernel-module-g-serial kernel-module-g-ether"
+MACHINE_EXTRA_RDEPENDS = "zaurusd"
+MACHINE_EXTRA_RRECOMMENDS_c7x0 = "kernel-module-snd-soc-corgi"
+MACHINE_EXTRA_RRECOMMENDS_akita = "kernel-module-snd-soc-spitz"
+MACHINE_EXTRA_RRECOMMENDS_spitz = "kernel-module-snd-soc-spitz"
-# Wireless Modules
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-hostap kernel-module-hostap-cs \
- kernel-module-hermes kernel-module-orinoco \
- kernel-module-orinoco-cs kernel-module-spectrum-cs \
- hostap-conf orinoco-conf"
-
-# Sound Modules
-BOOTSTRAP_EXTRA_RDEPENDS_append_c7x0 = " kernel-module-snd-soc-corgi "
-BOOTSTRAP_EXTRA_RDEPENDS_append_akita = " kernel-module-snd-soc-spitz "
-BOOTSTRAP_EXTRA_RDEPENDS_append_spitz = " kernel-module-snd-soc-spitz "
-# For OSS
-BOOTSTRAP_EXTRA_RDEPENDS += "kernel-module-snd-mixer-oss kernel-module-snd-pcm-oss" \ No newline at end of file