summaryrefslogtreecommitdiff
path: root/meta/packages/apt
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-08-21 14:00:13 +0000
committerRichard Purdie <richard@openedhand.com>2007-08-21 14:00:13 +0000
commit2075cb72ac072d658f68c15e1f0e1e41b1e96233 (patch)
treee13c6591b132cf6ed3faedff79ed4717a1d0767d /meta/packages/apt
parenta4b8304b62d6bf4b522769d5d9283050a5e63f3c (diff)
downloadopenembedded-core-2075cb72ac072d658f68c15e1f0e1e41b1e96233.tar.gz
openembedded-core-2075cb72ac072d658f68c15e1f0e1e41b1e96233.tar.bz2
openembedded-core-2075cb72ac072d658f68c15e1f0e1e41b1e96233.tar.xz
openembedded-core-2075cb72ac072d658f68c15e1f0e1e41b1e96233.zip
apt: Add db/db-native as a DEPENDS so apt-ftparchive gets built (needed by deb rootfs creation
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2531 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r--meta/packages/apt/apt-native.inc6
-rw-r--r--meta/packages/apt/apt-native_0.7.2.bb1
-rw-r--r--meta/packages/apt/apt-native_0.7.3.bb2
-rw-r--r--meta/packages/apt/apt.inc2
-rw-r--r--meta/packages/apt/files/db_linking_hack.patch27
5 files changed, 34 insertions, 4 deletions
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc
index 942f4991d..75cd8f47c 100644
--- a/meta/packages/apt/apt-native.inc
+++ b/meta/packages/apt/apt-native.inc
@@ -1,11 +1,13 @@
require apt.inc
inherit native
-DEPENDS += "dpkg-native curl-native"
+DEPENDS += "dpkg-native curl-native db-native"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}"
PACKAGES = ""
USE_NLS = "no"
+SRC_URI += "file://db_linking_hack.patch;patch=1"
+
python do_stage () {
bb.build.exec_func('do_stage_base', d)
bb.build.exec_func('do_stage_config', d)
@@ -35,7 +37,7 @@ do_stage_base () {
install -m 0755 bin/apt-get ${bindir}/
install -m 0755 bin/apt-config ${bindir}/
install -m 0755 bin/apt-cache ${bindir}/
-
+ install -m 0755 bin/apt-ftparchive ${bindir}/
install -m 0755 bin/apt-sortpkgs ${bindir}/
install -m 0755 bin/apt-extracttemplates ${bindir}/
diff --git a/meta/packages/apt/apt-native_0.7.2.bb b/meta/packages/apt/apt-native_0.7.2.bb
index 43f73889f..3342618aa 100644
--- a/meta/packages/apt/apt-native_0.7.2.bb
+++ b/meta/packages/apt/apt-native_0.7.2.bb
@@ -1,4 +1,5 @@
require apt-native.inc
+PR = "r1"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1"
diff --git a/meta/packages/apt/apt-native_0.7.3.bb b/meta/packages/apt/apt-native_0.7.3.bb
index 3342618aa..6db567f98 100644
--- a/meta/packages/apt/apt-native_0.7.3.bb
+++ b/meta/packages/apt/apt-native_0.7.3.bb
@@ -1,5 +1,5 @@
require apt-native.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://nodoc.patch;patch=1 \
file://noconfigure.patch;patch=1"
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc
index 6c9632e8f..92507be18 100644
--- a/meta/packages/apt/apt.inc
+++ b/meta/packages/apt/apt.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
-DEPENDS = "curl"
+DEPENDS = "curl db"
RDEPENDS = "dpkg"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
diff --git a/meta/packages/apt/files/db_linking_hack.patch b/meta/packages/apt/files/db_linking_hack.patch
new file mode 100644
index 000000000..3c8368b1e
--- /dev/null
+++ b/meta/packages/apt/files/db_linking_hack.patch
@@ -0,0 +1,27 @@
+Index: apt-0.7.3/configure.in
+===================================================================
+--- apt-0.7.3.orig/configure.in 2007-07-01 10:38:45.000000000 +0000
++++ apt-0.7.3/configure.in 2007-08-21 13:39:26.000000000 +0000
+@@ -67,8 +67,20 @@
+ [AC_DEFINE(HAVE_BDB)
+ BDBLIB="-ldb"
+ AC_MSG_RESULT(yes)],
+- [BDBLIB=""
+- AC_MSG_RESULT(no)]
++
++ LIBS="$LIBS -lpthread"
++ [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread)
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM(
++ [#include <db.h>],
++ [int r, s, t; db_version(&r, &s, &t);]
++ )],
++ [AC_DEFINE(HAVE_BDB)
++ BDBLIB="-ldb -lpthread"
++ AC_MSG_RESULT(yes)],
++ [BDBLIB=""
++ AC_MSG_RESULT(no)]
++ )]
+ )]
+ )
+