summaryrefslogtreecommitdiff
path: root/meta/packages/apt
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-07-17 09:57:09 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-07-17 09:57:09 +0000
commita906cd2a4b8ce4910b2e577e7ea56c7ec65e810c (patch)
treec83d43e68295f4af3a2c538b5287e909e1595ce0 /meta/packages/apt
parentab4f8bb493c7ecdad5bc9593a8057e5e981728d9 (diff)
downloadopenembedded-core-a906cd2a4b8ce4910b2e577e7ea56c7ec65e810c.tar.gz
openembedded-core-a906cd2a4b8ce4910b2e577e7ea56c7ec65e810c.tar.bz2
openembedded-core-a906cd2a4b8ce4910b2e577e7ea56c7ec65e810c.tar.xz
openembedded-core-a906cd2a4b8ce4910b2e577e7ea56c7ec65e810c.zip
apt: stage headers/libs
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4856 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r--meta/packages/apt/apt_0.7.14.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/packages/apt/apt_0.7.14.bb b/meta/packages/apt/apt_0.7.14.bb
index 0da36571e..efd7ab3bc 100644
--- a/meta/packages/apt/apt_0.7.14.bb
+++ b/meta/packages/apt/apt_0.7.14.bb
@@ -3,7 +3,7 @@ RDEPENDS = "dpkg"
require apt.inc
-PR = "r1"
+PR = "r2"
SRC_URI += "file://nodoc.patch;patch=1"
@@ -11,3 +11,14 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/apt-pkg
+ eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so
+
+ install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/
+}