summaryrefslogtreecommitdiff
path: root/meta/packages/beecrypt
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/beecrypt
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.bz2
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.xz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.zip
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/beecrypt')
-rw-r--r--meta/packages/beecrypt/beecrypt/disable-icu-check.patch41
-rw-r--r--meta/packages/beecrypt/beecrypt/fix-security.patch43
-rw-r--r--meta/packages/beecrypt/beecrypt/x64fix.patch23
-rw-r--r--meta/packages/beecrypt/beecrypt_4.1.2.bb21
4 files changed, 0 insertions, 128 deletions
diff --git a/meta/packages/beecrypt/beecrypt/disable-icu-check.patch b/meta/packages/beecrypt/beecrypt/disable-icu-check.patch
deleted file mode 100644
index 3e18a87c3..000000000
--- a/meta/packages/beecrypt/beecrypt/disable-icu-check.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-We are unable to run code at configure time in a cross environemnt, but as we
-control the build we can be fairly certain this dependency is met.
-
-JL 05/07/10
-Index: beecrypt-4.1.2/configure.ac
-===================================================================
---- beecrypt-4.1.2.orig/configure.ac 2004-12-21 11:37:56.000000000 +0000
-+++ beecrypt-4.1.2/configure.ac 2010-07-05 16:09:50.390083494 +0100
-@@ -243,32 +243,6 @@
- # Predefines and checks for C++ API support
- AH_TEMPLATE([CPPGLUE],[Define to 1 if you want to include the C++ code])
-
--if test "$ac_with_cplusplus" = yes; then
-- AC_MSG_CHECKING([for IBM's ICU library version >= 2.8])
-- AC_LANG_PUSH(C)
-- AC_RUN_IFELSE([
-- AC_LANG_PROGRAM([[#include <unicode/uversion.h>]],[[
-- #if U_ICU_VERSION_MAJOR_NUM < 2
-- exit(1);
-- #elif U_ICU_VERSION_MAJOR_NUM == 2
-- # if U_ICU_VERSION_MINOR_NUM < 8
-- exit(1);
-- # else
-- exit(0);
-- # endif
-- #else
-- exit(0);
-- #endif
-- ]])],[
-- AC_MSG_RESULT([yes])
-- ],[
-- AC_MSG_RESULT([no])
-- AC_MSG_WARN([disabling cplusplus])
-- ac_with_cplusplus=no
-- ])
-- AC_LANG_POP(C)
--fi
--
- if test "$ac_with_cplusplus" = yes ; then
- AC_DEFINE([CPPGLUE],1)
- fi
diff --git a/meta/packages/beecrypt/beecrypt/fix-security.patch b/meta/packages/beecrypt/beecrypt/fix-security.patch
deleted file mode 100644
index 6103562e0..000000000
--- a/meta/packages/beecrypt/beecrypt/fix-security.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Fix visibility of various C++ functions, inspired by a similar patch in the Fink
-project:
-http://www.mail-archive.com/fink-commits@lists.sourceforge.net/msg75742.html
-
-JL 05/07/10
-Index: beecrypt-4.1.2/c++/security/Security.h
-===================================================================
---- beecrypt-4.1.2.orig/c++/security/Security.h 2010-07-05 17:15:34.811273306 +0100
-+++ beecrypt-4.1.2/c++/security/Security.h 2010-07-05 17:15:38.696388531 +0100
-@@ -75,8 +75,6 @@
- public:
- typedef vector<const Provider*> provider_vector;
- typedef provider_vector::iterator provider_vector_iterator;
--
-- private:
- struct spi
- {
- Object* cspi;
-@@ -91,6 +89,7 @@
- static spi* getSpi(const String& algo, const String& type, const Provider&) throw (NoSuchAlgorithmException);
- static spi* getFirstSpi(const String& type);
-
-+ private:
- static const String& getKeyStoreDefault();
-
- static bool _init;
-Index: beecrypt-4.1.2/c++/beeyond/BeeCertificate.h
-===================================================================
---- beecrypt-4.1.2.orig/c++/beeyond/BeeCertificate.h 2004-11-03 09:37:27.000000000 +0000
-+++ beecrypt-4.1.2/c++/beeyond/BeeCertificate.h 2010-07-05 17:16:25.216332324 +0100
-@@ -150,11 +150,11 @@
- mutable String* str;
-
- BeeCertificate();
-- BeeCertificate(InputStream& in) throw (IOException);
-
- bytearray* encodeTBS() const;
-
- public:
-+ BeeCertificate(InputStream& in) throw (IOException);
- BeeCertificate(const BeeCertificate&);
- virtual ~BeeCertificate();
-
diff --git a/meta/packages/beecrypt/beecrypt/x64fix.patch b/meta/packages/beecrypt/beecrypt/x64fix.patch
deleted file mode 100644
index ac02425d5..000000000
--- a/meta/packages/beecrypt/beecrypt/x64fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Don't have 64 appended to the libdir for 64bit platforms.
-
-JL 05/07/10
-Index: beecrypt-4.1.2/configure.ac
-===================================================================
---- beecrypt-4.1.2.orig/configure.ac 2010-07-05 16:39:43.000000000 +0100
-+++ beecrypt-4.1.2/configure.ac 2010-07-05 16:40:27.521082866 +0100
-@@ -585,15 +585,6 @@
-
- # Check where to install the libraries
- bc_libalt=
--case $target_os in
--linux*)
-- case $bc_target_arch in
-- powerpc64 | s390x | x86_64)
-- bc_libalt="64"
-- ;;
-- esac
-- ;;
--esac
- AC_SUBST(LIBALT,$bc_libalt)
-
- # Generate output files.
diff --git a/meta/packages/beecrypt/beecrypt_4.1.2.bb b/meta/packages/beecrypt/beecrypt_4.1.2.bb
deleted file mode 100644
index 6eb40e5d5..000000000
--- a/meta/packages/beecrypt/beecrypt_4.1.2.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-# Beecrypt OE build file
-# Copyright (C) 2004-2005, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
-DESCRIPTION="Beecrypt is a general-purpose cryptography library."
-HOMEPAGE="http://sourceforge.net/projects/beecrypt"
-SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
- file://x64fix.patch \
- file://disable-icu-check.patch \
- file://fix-security.patch"
-
-DEPENDS = "icu"
-
-PR = "r0"
-
-inherit autotools
-acpaths=""
-
-EXTRA_OECONF="--with-arch=${TARGET_ARCH} --without-python --enable-shared --enable-static"
-
-BBCLASSEXTEND = "native"