summaryrefslogtreecommitdiff
path: root/meta/packages/bluez/bluez4_4.66.bb
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-06-26 16:04:00 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:18:01 +0100
commita5af9cfb4c9da5590335d4e1df88c61aaf7dcb12 (patch)
tree787905d4f73c8650c0e9502bac0c3136cc828516 /meta/packages/bluez/bluez4_4.66.bb
parent342c016356e4a05b7a22be1723257ca29e17678e (diff)
downloadopenembedded-core-a5af9cfb4c9da5590335d4e1df88c61aaf7dcb12.tar.gz
openembedded-core-a5af9cfb4c9da5590335d4e1df88c61aaf7dcb12.tar.bz2
openembedded-core-a5af9cfb4c9da5590335d4e1df88c61aaf7dcb12.tar.xz
openembedded-core-a5af9cfb4c9da5590335d4e1df88c61aaf7dcb12.zip
bluez4: Upgraded to version 4.66
Change the local file directory name to ${PN}-${PV} Comment for local patches Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta/packages/bluez/bluez4_4.66.bb')
-rw-r--r--meta/packages/bluez/bluez4_4.66.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/bluez/bluez4_4.66.bb b/meta/packages/bluez/bluez4_4.66.bb
new file mode 100644
index 000000000..59193c2f9
--- /dev/null
+++ b/meta/packages/bluez/bluez4_4.66.bb
@@ -0,0 +1,68 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-lib libusb-compat dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+
+ASNEEDED = ""
+
+PR = "r0"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
+ file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"