summaryrefslogtreecommitdiff
path: root/meta/packages/bzip2/bzip2-full-native-1.0.5
diff options
context:
space:
mode:
authorJoshua Lock <josh@openedhand.com>2008-09-23 03:30:23 +0000
committerJoshua Lock <josh@openedhand.com>2008-09-23 03:30:23 +0000
commite419523cbf54ee3d3d05325ad9ab5d09c52e8308 (patch)
treede115e148fe58cc13190c4771352318e5995a716 /meta/packages/bzip2/bzip2-full-native-1.0.5
parent6e1a993ecc25b3691400992f794288c685211d06 (diff)
downloadopenembedded-core-e419523cbf54ee3d3d05325ad9ab5d09c52e8308.tar.gz
openembedded-core-e419523cbf54ee3d3d05325ad9ab5d09c52e8308.tar.bz2
openembedded-core-e419523cbf54ee3d3d05325ad9ab5d09c52e8308.tar.xz
openembedded-core-e419523cbf54ee3d3d05325ad9ab5d09c52e8308.zip
Add a bzip2-full-native recipe and make the python-native recipe depend on it.
Yum requires bzip2 support in Python so our native Python package needs something to provide it. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5233 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/bzip2/bzip2-full-native-1.0.5')
-rw-r--r--meta/packages/bzip2/bzip2-full-native-1.0.5/Makefile.am41
-rw-r--r--meta/packages/bzip2/bzip2-full-native-1.0.5/configure.ac14
2 files changed, 55 insertions, 0 deletions
diff --git a/meta/packages/bzip2/bzip2-full-native-1.0.5/Makefile.am b/meta/packages/bzip2/bzip2-full-native-1.0.5/Makefile.am
new file mode 100644
index 000000000..b234e80f3
--- /dev/null
+++ b/meta/packages/bzip2/bzip2-full-native-1.0.5/Makefile.am
@@ -0,0 +1,41 @@
+
+lib_LTLIBRARIES = libbz2.la
+
+libbz2_la_SOURCES = blocksort.c \
+ huffman.c \
+ crctable.c \
+ randtable.c \
+ compress.c \
+ decompress.c \
+ bzlib.c
+
+bin_PROGRAMS = bzip2 bzip2recover
+
+bzip2_SOURCES = bzip2.c
+bzip2_LDADD = libbz2.la
+bzip2_DEPENDENCIES = libbz2.la
+
+include_HEADERS = bzlib.h
+
+bzip2recover_SOURCES = bzip2recover.c
+bzip2recover_LDADD = libbz2.la
+bzip2recover_DEPENDENCIES = libbz2.la
+
+bin_SCRIPTS = bzgrep bzgrep bzmore bzdiff
+
+man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
+EXTRA_DIST = $(man_MANS)
+
+install-exec-hook:
+ ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bunzip2$(EXEEXT)
+ ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bzcat$(EXEEXT)
+ ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzegrep$(EXEEXT)
+ ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzfgrep$(EXEEXT)
+ ln -s $(bindir)/bzmore$(EXEEXT) $(DESTDIR)$(bindir)/bzless$(EXEEXT)
+ ln -s $(bindir)/bzdiff$(EXEEXT) $(DESTDIR)$(bindir)/bzcmp$(EXEEXT)
+
+install-data-hook:
+ echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzegrep.1
+ echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzfgrep.1
+ echo ".so man1/bzmore.1" > $(DESTDIR)$(mandir)/man1/bzless.1
+ echo ".so man1/bzdiff.1" > $(DESTDIR)$(mandir)/man1/bzcmp.1
diff --git a/meta/packages/bzip2/bzip2-full-native-1.0.5/configure.ac b/meta/packages/bzip2/bzip2-full-native-1.0.5/configure.ac
new file mode 100644
index 000000000..14b1d1809
--- /dev/null
+++ b/meta/packages/bzip2/bzip2-full-native-1.0.5/configure.ac
@@ -0,0 +1,14 @@
+AC_PREREQ([2.57])
+
+AC_INIT(bzip2, 2.0.5, , libXrender)
+AM_INIT_AUTOMAKE()
+AM_MAINTAINER_MODE
+
+#AM_CONFIG_HEADER(config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+AC_OUTPUT([Makefile])
+