summaryrefslogtreecommitdiff
path: root/meta/packages/bzip2/bzip2_1.0.5.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-06-26 19:34:56 +0000
committerRichard Purdie <richard@openedhand.com>2008-06-26 19:34:56 +0000
commit8722fb9b43a434a310babbfa50c077d472cd3387 (patch)
tree5d421e22613d7bdef69f19dccc0870b61dfc0ba8 /meta/packages/bzip2/bzip2_1.0.5.bb
parent85221a39bc256f5a8116b35ff9eddd97affafa07 (diff)
downloadopenembedded-core-8722fb9b43a434a310babbfa50c077d472cd3387.tar.gz
openembedded-core-8722fb9b43a434a310babbfa50c077d472cd3387.tar.bz2
openembedded-core-8722fb9b43a434a310babbfa50c077d472cd3387.tar.xz
openembedded-core-8722fb9b43a434a310babbfa50c077d472cd3387.zip
bzip2: Add 1.0.5 and autotool it
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4736 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/bzip2/bzip2_1.0.5.bb')
-rw-r--r--meta/packages/bzip2/bzip2_1.0.5.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/bzip2/bzip2_1.0.5.bb b/meta/packages/bzip2/bzip2_1.0.5.bb
new file mode 100644
index 000000000..04e55e308
--- /dev/null
+++ b/meta/packages/bzip2/bzip2_1.0.5.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Very high-quality data compression program."
+SECTION = "console/utils"
+PR = "r0"
+
+LICENSE = "bzip2"
+SRC_URI = "http://www.bzip.org/1.0.5/bzip2-1.0.5.tar.gz \
+ file://configure.ac \
+ file://Makefile.am"
+
+CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
+
+inherit autotools
+
+do_configure_prepend () {
+ cp ${WORKDIR}/configure.ac ${S}/
+ cp ${WORKDIR}/Makefile.am ${S}/
+ cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
+}
+
+do_install_append () {
+ mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
+ mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+}
+
+do_stage () {
+ install -m 0644 bzlib.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so libbz2 ${STAGING_LIBDIR}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
+ update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove bunzip2 bunzip2.${PN}
+ update-alternatives --remove bzcat bzcat.${PN}
+}