summaryrefslogtreecommitdiff
path: root/meta/packages/clutter/moblin-proto
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/clutter/moblin-proto
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.bz2
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.xz
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.zip
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/clutter/moblin-proto')
-rw-r--r--meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch44
-rw-r--r--meta/packages/clutter/moblin-proto/fix.patch22
-rw-r--r--meta/packages/clutter/moblin-proto/paths.patch15
3 files changed, 0 insertions, 81 deletions
diff --git a/meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch b/meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch
deleted file mode 100644
index 4a3eddb8c..000000000
--- a/meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e05b5b7..c348a1e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -64,7 +64,7 @@ HFILES = $(wildcard *.h)
- %.o: %.c $(HFILES)
- $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
- $(BINARY): $(OBJECTS)
-- $(CXX) -o $@ $(OBJECTS) $(LIBS)
-+ $(CXX) -rdynamic -o $@ $(OBJECTS) $(LIBS)
-
- #$(BINARY): $(CFILES)
- # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
-diff --git a/moblin-desktop.c b/moblin-desktop.c
-index 6dd4f2c..fb9d231 100644
---- a/moblin-desktop.c
-+++ b/moblin-desktop.c
-@@ -103,6 +103,8 @@ void moblin_blur (void)
- if (desktop->maincopy)
- return;
-
-+ if (clutter_feature_available (CLUTTER_FEATURE_SHADERS_GLSL))
-+ {
- #if 0
- desktop->maincopy = clutter_texture_new_from_actor (desktop->mainstuff);
- #else
-@@ -158,6 +160,17 @@ void moblin_blur (void)
- 1.0f / moblin_desktop_width ());
- }
- clutter_actor_set_shader_param (desktop->maincopy, "radius", 3.0);
-+ }
-+ else
-+ {
-+ ClutterColor clr= { 0x44, 0x44, 0x44, 0x77 };
-+ guint w, h;
-+
-+ desktop->maincopy = clutter_rectangle_new_with_color (&clr);
-+ clutter_actor_get_size (desktop->mainstuff, &w, &h);
-+ clutter_actor_set_size (desktop->maincopy, w, h);
-+ clutter_group_add (desktop->copyholder, desktop->maincopy);
-+ }
- }
-
- void moblin_unblur (void)
diff --git a/meta/packages/clutter/moblin-proto/fix.patch b/meta/packages/clutter/moblin-proto/fix.patch
deleted file mode 100644
index 8bde67762..000000000
--- a/meta/packages/clutter/moblin-proto/fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100
-+++ git/Makefile 2008-08-12 12:16:52.000000000 +0100
-@@ -15,7 +15,7 @@
-
- SCP_DESTINATION=pug.vpn:tmp
-
--BINARY=$(shell basename `pwd`)#
-+BINARY=moblin-proto
- PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here
-
- #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d
-@@ -61,7 +61,7 @@
- %.o: %.c $(HFILES)
- $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
- $(BINARY): $(OBJECTS)
-- $(CC) -o $@ $(OBJECTS) $(LIBS)
-+ $(CXX) -o $@ $(OBJECTS) $(LIBS)
-
- #$(BINARY): $(CFILES)
- # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
diff --git a/meta/packages/clutter/moblin-proto/paths.patch b/meta/packages/clutter/moblin-proto/paths.patch
deleted file mode 100644
index d241c8ff7..000000000
--- a/meta/packages/clutter/moblin-proto/paths.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/moblin-desktop.h b/moblin-desktop.h
-index 880a9ad..3d51a14 100644
---- a/moblin-desktop.h
-+++ b/moblin-desktop.h
-@@ -29,8 +29,8 @@
- #define __MAIN_H__
-
-
--#define ASSET_ROOT "./assets/"
--#define JSON_ROOT "./layouts/"
-+#define ASSET_ROOT "/usr/share/moblin-proto/assets/"
-+#define JSON_ROOT "/usr/share/moblin-proto/layouts/"
-
- typedef struct
- {