summaryrefslogtreecommitdiff
path: root/meta/packages/clutter
diff options
context:
space:
mode:
authorRobert Bradford <rob@openedhand.com>2008-04-25 16:23:33 +0000
committerRobert Bradford <rob@openedhand.com>2008-04-25 16:23:33 +0000
commitf3e36a17bec4029a432f66e3b1f9893a186fbae4 (patch)
tree3729904bf8ff1964fedb4c66d0113da6ad2d6e15 /meta/packages/clutter
parentdf99aabf64b2ab10cb0a0ed44f129c8cc4bb422e (diff)
downloadopenembedded-core-f3e36a17bec4029a432f66e3b1f9893a186fbae4.tar.gz
openembedded-core-f3e36a17bec4029a432f66e3b1f9893a186fbae4.tar.bz2
openembedded-core-f3e36a17bec4029a432f66e3b1f9893a186fbae4.tar.xz
openembedded-core-f3e36a17bec4029a432f66e3b1f9893a186fbae4.zip
Refresh enable_tests.patch for clutter trunk.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4345 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/clutter')
-rw-r--r--meta/packages/clutter/clutter/enable_tests.patch58
1 files changed, 27 insertions, 31 deletions
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
index 4f78df5b8..4a99968fa 100644
--- a/meta/packages/clutter/clutter/enable_tests.patch
+++ b/meta/packages/clutter/clutter/enable_tests.patch
@@ -6,17 +6,26 @@
Index: clutter/tests/Makefile.am
===================================================================
---- clutter.orig/tests/Makefile.am 2007-11-06 12:29:17.000000000 +0000
-+++ clutter/tests/Makefile.am 2007-11-06 12:30:11.000000000 +0000
+--- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \
+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \
test-actors test-behave test-text test-entry test-project \
- test-boxes test-perspective test-rotate test-depth \
- test-threads test-timeline test-score test-script
-@@ -26,4 +26,9 @@ test_timeline_SOURCES = test-timeline.c
- test_score_SOURCES = test-score.c
- test_script_SOURCES = test-script.c
+ test-perspective test-rotate test-depth \
+ test-threads test-timeline test-timeline-dup-frames \
+@@ -14,7 +14,7 @@
+ test-cogl-tex-polygon test-stage-read-pixels
+
+ if X11_TESTS
+-noinst_PROGRAMS += test-pixmap
++bin_PROGRAMS += test-pixmap
+ endif
+
+ INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter
+@@ -61,4 +61,9 @@
+ test_cogl_offscreen_SOURCES = test-cogl-offscreen.c
+ test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
+test_textdir = $(pkgdatadir)
+test_text_DATA = test-text.c
@@ -26,27 +35,14 @@ Index: clutter/tests/Makefile.am
EXTRA_DIST = redhand.png test-script.json
Index: clutter/tests/test-actors.c
===================================================================
---- clutter.orig/tests/test-actors.c 2007-11-06 12:29:17.000000000 +0000
-+++ clutter/tests/test-actors.c 2007-11-06 12:29:21.000000000 +0000
-@@ -143,7 +143,7 @@ main (int argc, char *argv[])
- stage = clutter_stage_get_default ();
- clutter_actor_set_size (stage, 800, 600);
-
-- pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL);
-+ pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL);
-
- if (!pixbuf)
- g_error("pixbuf load failed");
-Index: clutter/tests/test-text.c
-===================================================================
---- clutter.orig/tests/test-text.c 2007-11-06 12:29:17.000000000 +0000
-+++ clutter/tests/test-text.c 2007-11-06 12:29:21.000000000 +0000
-@@ -27,7 +27,7 @@ main (int argc, char *argv[])
-
- stage = clutter_stage_get_default ();
-
-- if (!g_file_get_contents ("test-text.c", &text, &size, NULL))
-+ if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL))
- g_error("g_file_get_contents() of test-text.c failed");
-
- clutter_actor_set_size (stage, 800, 600);
+--- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
++++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100
+@@ -184,7 +184,7 @@
+ /* Create a texture from file, then clone in to same resources */
+ if (i == 0)
+ {
+- if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png",
++ if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png",
+ &error)) == NULL)
+ {
+ g_error ("image load failed: %s", error->message);