summaryrefslogtreecommitdiff
path: root/meta/packages/connman
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/connman
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.bz2
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.xz
openembedded-core-29d6678fd546377459ef75cf54abeef5b969b5cf.zip
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/connman')
-rw-r--r--meta/packages/connman/connman-gnome_git.bb9
-rw-r--r--meta/packages/connman/connman.inc43
-rw-r--r--meta/packages/connman/connman_0.48.bb7
-rw-r--r--meta/packages/connman/connman_git.bb10
-rwxr-xr-xmeta/packages/connman/files/connman42
-rw-r--r--meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch13
-rw-r--r--meta/packages/connman/files/connman-install-tests.patch15
-rw-r--r--meta/packages/connman/files/dbusperms.patch12
-rw-r--r--meta/packages/connman/files/udevfix.patch12
9 files changed, 0 insertions, 163 deletions
diff --git a/meta/packages/connman/connman-gnome_git.bb b/meta/packages/connman/connman-gnome_git.bb
deleted file mode 100644
index 440ba285c..000000000
--- a/meta/packages/connman/connman-gnome_git.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-
-SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman-gnome.git;protocol=git"
-DEPENDS = "gtk+"
-PV = "0.1+git${SRCPV}"
-PR = "r0"
-
-S = "${WORKDIR}/git"
-
-inherit autotools
diff --git a/meta/packages/connman/connman.inc b/meta/packages/connman/connman.inc
deleted file mode 100644
index 9a623d7f4..000000000
--- a/meta/packages/connman/connman.inc
+++ /dev/null
@@ -1,43 +0,0 @@
-HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
-SUMMARY = "Moblin Connection Manager"
-LICENSE = "GPL"
-
-DEPENDS = "libgdbus dbus glib-2.0 hal"
-RDEPENDS_${PN} = "dhcp-client wpa-supplicant resolvconf"
-
-EXTRA_OECONF += " \
- --enable-ethernet=builtin --enable-wifi=builtin --enable-dhclient=builtin \
- --enable-bluetooth=builtin --enable-udev --enable-loopback=builtin \
- --enable-dnsproxy=builtin --enable-threads --enable-resolvconf=builtin \
- --enable-client --enable-fake --with-dhclient=/sbin/dhclient \
- --enable-test \
- ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant"
-
-INITSCRIPT_NAME = "connman"
-INITSCRIPT_PARAMS = "start 05 5 2 . stop 22 0 1 6 ."
-
-inherit autotools pkgconfig update-rc.d
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
-}
-
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
-FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
- ${sysconfdir} ${sharedstatedir} ${localstatedir} \
- ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
- ${datadir}/pixmaps ${datadir}/applications \
- ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
- ${libdir}/bonobo/servers \
- ${libdir}/${PN}/test/* \
- ${datadir}/dbus-1/system-services/* \
- ${libdir}/connman/scripts/dhclient*"
-FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
- ${libdir}/connman/scripts/.debug"
-
-python populate_packages_prepend() {
- plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
- plugin_name = bb.data.expand('${PN}-plugin-%s', d)
- do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
-} \ No newline at end of file
diff --git a/meta/packages/connman/connman_0.48.bb b/meta/packages/connman/connman_0.48.bb
deleted file mode 100644
index 269f98721..000000000
--- a/meta/packages/connman/connman_0.48.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require connman.inc
-PR = "r0"
-
-SRC_URI = "http://www.kernel.org/pub/linux/network/connman/${P}.tar.bz2 \
- file://dbusperms.patch \
- file://connman "
-
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb
deleted file mode 100644
index 82cd976e5..000000000
--- a/meta/packages/connman/connman_git.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require connman.inc
-
-PV = "0.47+git${SRCPV}"
-PR = "r17"
-S = "${WORKDIR}/git"
-
-SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \
- file://dbusperms.patch \
- file://connman "
-
diff --git a/meta/packages/connman/files/connman b/meta/packages/connman/files/connman
deleted file mode 100755
index f8154f68f..000000000
--- a/meta/packages/connman/files/connman
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-
-DAEMON=/usr/sbin/connmand
-PIDFILE=/var/run/connmand.pid
-DESC="Connection Manager"
-
-if [ -f /etc/default/connman ] ; then
- . /etc/default/connman
-fi
-
-set -e
-
-do_start() {
- $DAEMON
-}
-
-do_stop() {
- start-stop-daemon --stop --name connmand --quiet
-}
-
-case "$1" in
- start)
- echo "Starting $DESC"
- do_start
- ;;
- stop)
- echo "Stopping $DESC"
- do_stop
- ;;
- restart|force-reload)
- echo "Restarting $DESC"
- do_stop
- sleep 1
- do_start
- ;;
- *)
- echo "Usage: $0 {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch b/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
deleted file mode 100644
index 57df7196e..000000000
--- a/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: git/test/Makefile.am
-===================================================================
---- git.orig/test/Makefile.am 2009-05-21 12:07:39.000000000 +0100
-+++ git/test/Makefile.am 2009-05-21 17:29:33.000000000 +0100
-@@ -1,5 +1,7 @@
-
--EXTRA_DIST = get-state list-profiles list-services \
-+testdir = $(pkgdatadir)/tests
-+
-+test_SCRIPTS = get-state list-profiles list-services \
- list-connections select-connection \
- list-devices enable-device disable-device start-scanning \
- list-networks select-network disable-network create-network \
diff --git a/meta/packages/connman/files/connman-install-tests.patch b/meta/packages/connman/files/connman-install-tests.patch
deleted file mode 100644
index 0ea3758f2..000000000
--- a/meta/packages/connman/files/connman-install-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: git/Makefile.am
-===================================================================
---- git.orig/Makefile.am 2009-08-24 15:56:33.000000000 +0100
-+++ git/Makefile.am 2009-08-24 16:02:38.000000000 +0100
-@@ -115,7 +115,9 @@
- tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
- endif
-
--EXTRA_DIST += test/get-state test/list-profiles test/list-services \
-+testdir = $(pkgdatadir)/tests
-+
-+test_SCRIPTS = test/get-state test/list-profiles test/list-services \
- test/connect-service test/list-connections \
- test/select-connection test/list-devices test/enable-device \
- test/disable-device test/start-scanning test/list-networks \
diff --git a/meta/packages/connman/files/dbusperms.patch b/meta/packages/connman/files/dbusperms.patch
deleted file mode 100644
index 100af0367..000000000
--- a/meta/packages/connman/files/dbusperms.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: git/src/connman-dbus.conf
-===================================================================
---- git.orig/src/connman-dbus.conf 2009-05-26 00:34:35.000000000 +0100
-+++ git/src/connman-dbus.conf 2009-05-26 00:34:48.000000000 +0100
-@@ -10,6 +10,6 @@
- <allow send_destination="org.moblin.connman"/>
- </policy>
- <policy context="default">
-- <deny send_destination="org.moblin.connman"/>
-+ <allow send_destination="org.moblin.connman"/>
- </policy>
- </busconfig>
diff --git a/meta/packages/connman/files/udevfix.patch b/meta/packages/connman/files/udevfix.patch
deleted file mode 100644
index 803bec528..000000000
--- a/meta/packages/connman/files/udevfix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: git/src/connman.rules
-===================================================================
---- git.orig/src/connman.rules 2009-05-25 14:24:53.000000000 +0100
-+++ git/src/connman.rules 2009-05-25 14:25:16.000000000 +0100
-@@ -3,6 +3,7 @@
-
- SUBSYSTEM=="net", KERNEL=="eth*", ENV{CONNMAN_TYPE}="ethernet"
- SUBSYSTEM=="net", KERNEL=="wlan*", ENV{CONNMAN_TYPE}="wifi"
-+SUBSYSTEM=="net", KERNEL=="ra0", ENV{CONNMAN_TYPE}="wifi"
-
- SUBSYSTEM=="net", DRIVERS=="hso", ENV{CONNMAN_TYPE}="hso"
-