summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus-native_1.1.2.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-01-15 13:48:16 +0000
committerRoss Burton <ross@openedhand.com>2008-01-15 13:48:16 +0000
commit9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81 (patch)
tree2c723e670a4308bc545e4919cd305c02522f667b /meta/packages/dbus/dbus-native_1.1.2.bb
parentba56fb85c8c75c961671073cc9aeeb9f260f6439 (diff)
downloadopenembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.gz
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.bz2
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.xz
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.zip
dbus: bump -bleeding from 1.1.1 to 1.1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3491 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus/dbus-native_1.1.2.bb')
-rw-r--r--meta/packages/dbus/dbus-native_1.1.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-native_1.1.2.bb b/meta/packages/dbus/dbus-native_1.1.2.bb
new file mode 100644
index 000000000..e2fb48382
--- /dev/null
+++ b/meta/packages/dbus/dbus-native_1.1.2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ file://fix-validate.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
+ --disable-doxygen-docs --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}