summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus-native_1.2.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-05 17:04:39 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-05 17:04:39 +0000
commit0d8a8c893226ec11bdfb51466199e1d748875338 (patch)
treea68fba4ce96cb15879041dd8e096ecb3b73db937 /meta/packages/dbus/dbus-native_1.2.4.bb
parenteae7eb5bd559c1f4ae843820f2d4105066b3cc45 (diff)
downloadopenembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.tar.gz
openembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.tar.bz2
openembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.tar.xz
openembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.zip
dbus-native: Generate the dbus-bus-introspect.xml so dbus-glib recipes don't have to find the dbus source. Pass the location of the file to dbus-glib* with the --with-introspect and drop the now unneeded patch
Diffstat (limited to 'meta/packages/dbus/dbus-native_1.2.4.bb')
-rw-r--r--meta/packages/dbus/dbus-native_1.2.4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-native_1.2.4.bb b/meta/packages/dbus/dbus-native_1.2.4.bb
index 29fd5a2cb..617a8f95b 100644
--- a/meta/packages/dbus/dbus-native_1.2.4.bb
+++ b/meta/packages/dbus/dbus-native_1.2.4.bb
@@ -3,6 +3,8 @@ inherit native
DEPENDS = "glib-2.0-native libxml2-native expat-native"
+PR = "r1"
+
do_stage() {
oe_runmake install
autotools_stage_all
@@ -10,6 +12,11 @@ do_stage() {
# for dbus-glib-native introspection generation
install -d ${STAGING_DATADIR}/dbus
install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+
+ # dbus-glib-native and dbus-glib need this xml file
+ install -d ${STAGING_DATADIR_NATIVE}/dbus/
+ cd ${S}
+ ./bus/dbus-daemon --introspect > ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml
}
do_install() {