summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus_1.1.2.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-01-15 13:48:16 +0000
committerRoss Burton <ross@openedhand.com>2008-01-15 13:48:16 +0000
commit9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81 (patch)
tree2c723e670a4308bc545e4919cd305c02522f667b /meta/packages/dbus/dbus_1.1.2.bb
parentba56fb85c8c75c961671073cc9aeeb9f260f6439 (diff)
downloadopenembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.gz
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.bz2
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.xz
openembedded-core-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.zip
dbus: bump -bleeding from 1.1.1 to 1.1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3491 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus/dbus_1.1.2.bb')
-rw-r--r--meta/packages/dbus/dbus_1.1.2.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus_1.1.2.bb b/meta/packages/dbus/dbus_1.1.2.bb
new file mode 100644
index 000000000..93846bd82
--- /dev/null
+++ b/meta/packages/dbus/dbus_1.1.2.bb
@@ -0,0 +1,65 @@
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl"
+
+PR = "r0"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch;patch=1 \
+ file://dbus-1.init \
+ file://cross.patch;patch=1 \
+ file://fix-install-daemon.patch;patch=1 \
+ file://fix-validate.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig update-rc.d gettext
+
+INITSCRIPT_NAME = "dbus-1"
+INITSCRIPT_PARAMS = "defaults"
+
+CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf"
+
+FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include"
+
+pkg_postinst_dbus() {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+MESSAGEUSER=messagebus
+MESSAGEHOME=/var/run/dbus
+
+mkdir -p $MESSAGEHOME || true
+chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
+chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER"
+}
+
+EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \
+ --disable-doxygen-docs --with-xml=expat --without-x"
+
+do_stage () {
+ oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR}
+
+ autotools_stage_includes
+
+ mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+ install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/
+}
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_dbus', 'dbus-1', d)
+}