summaryrefslogtreecommitdiff
path: root/meta/packages/eds/eds-dbus/optional_imapx_provider.patch
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-07-16 08:08:30 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 16:00:54 +0100
commit37eb35995f3d4d75ef57987d5d924b23c40e83e2 (patch)
treebf6ce9ca12d0c277bb39246b0a2af422792b1d63 /meta/packages/eds/eds-dbus/optional_imapx_provider.patch
parent2d631851753cef1b9d4088accb5e83bb101b281b (diff)
downloadopenembedded-core-37eb35995f3d4d75ef57987d5d924b23c40e83e2.tar.gz
openembedded-core-37eb35995f3d4d75ef57987d5d924b23c40e83e2.tar.bz2
openembedded-core-37eb35995f3d4d75ef57987d5d924b23c40e83e2.tar.xz
openembedded-core-37eb35995f3d4d75ef57987d5d924b23c40e83e2.zip
eds-dbus: Update to 2.30.2 from git repo
Also backport a patch from upstream(f001953f7d60) to compile imapx provider optionally, which is the default behavior of current version. Else we get build error when compiling imapx. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/packages/eds/eds-dbus/optional_imapx_provider.patch')
-rw-r--r--meta/packages/eds/eds-dbus/optional_imapx_provider.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/eds/eds-dbus/optional_imapx_provider.patch b/meta/packages/eds/eds-dbus/optional_imapx_provider.patch
new file mode 100644
index 000000000..128307a5f
--- /dev/null
+++ b/meta/packages/eds/eds-dbus/optional_imapx_provider.patch
@@ -0,0 +1,62 @@
+Index: git/camel/providers/Makefile.am
+===================================================================
+--- git.orig/camel/providers/Makefile.am 2010-07-06 18:49:34.000000000 +0800
++++ git/camel/providers/Makefile.am 2010-07-08 17:23:56.000000000 +0800
+@@ -6,6 +6,10 @@
+ IMAP4_DIR=imap4
+ endif
+
++if ENABLE_IMAPX
++IMAPX_DIR=imapx
++endif
++
+ if ENABLE_HULA
+ HULA_DIR=hula
+ endif
+@@ -15,6 +19,6 @@
+ SENDMAIL_DIR=sendmail
+ endif
+
+-SUBDIRS = pop3 $(SENDMAIL_DIR) smtp imap imapx $(IMAP4_DIR) $(NNTP_DIR) local groupwise $(HULA_DIR)
++SUBDIRS = pop3 $(SENDMAIL_DIR) smtp imap $(IMAPX_DIR) $(IMAP4_DIR) $(NNTP_DIR) local groupwise $(HULA_DIR)
+
+ -include $(top_srcdir)/git.mk
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2010-07-08 17:24:36.000000000 +0800
++++ git/configure.ac 2010-07-08 17:32:06.000000000 +0800
+@@ -1002,6 +1002,26 @@
+ AM_CONDITIONAL(ENABLE_IMAP4, [test x$enable_imap4 = xyes])
+
+ dnl ******************************
++dnl IMAPX code support.
++dnl ******************************
++AC_ARG_ENABLE(imapx,
++ AS_HELP_STRING([--enable-imapx=no/yes],
++ [Attempt to compile yet another, incomplete, very unsupported IMAPv4r1 implementation]),
++ [],[enable_imapx=no])
++
++if test "x$enable_imapx" = "xyes"; then
++ AC_DEFINE(ENABLE_IMAPX,1,[Really don't try this at home])
++ AC_PATH_PROG(GPERF, gperf)
++ if test -z "$GPERF" ; then
++ AC_MSG_ERROR([You need gperf to compile imapx provider])
++ fi
++ msg_imapx=yes
++else
++ msg_imapx=no
++fi
++AM_CONDITIONAL(ENABLE_IMAPX, [test x$enable_imapx = xyes])
++
++dnl ******************************
+ dnl Hula support
+ dnl ******************************
+ AC_ARG_ENABLE([hula],
+@@ -1541,3 +1561,7 @@
+ if test "x$msg_hula" = "xyes"; then
+ echo "Hula support: $msg_hula"
+ fi
++
++if test "x$msg_imapx" = "xyes"; then
++ echo "IMAPX support: $msg_imapx"
++fi