summaryrefslogtreecommitdiff
path: root/meta/packages/eds
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-26 19:02:44 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:07:04 +0000
commite380b48602db316c7d12d328192eadc52e5be861 (patch)
tree78d1c6d7742c79216b01fb0b739adea44c85dc51 /meta/packages/eds
parentf9f549d06fd787f93c9c0af607683d0521fcd827 (diff)
downloadopenembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.gz
openembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.bz2
openembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.xz
openembedded-core-e380b48602db316c7d12d328192eadc52e5be861.zip
classes/autotools_stage.bbclass: Add autotools_stage class to simplify recipes using standard autotools
Diffstat (limited to 'meta/packages/eds')
-rw-r--r--meta/packages/eds/eds-dbus_2.20.0.bb6
-rw-r--r--meta/packages/eds/eds-dbus_svn.bb6
2 files changed, 2 insertions, 10 deletions
diff --git a/meta/packages/eds/eds-dbus_2.20.0.bb b/meta/packages/eds/eds-dbus_2.20.0.bb
index 424194fd1..76694ce5a 100644
--- a/meta/packages/eds/eds-dbus_2.20.0.bb
+++ b/meta/packages/eds/eds-dbus_2.20.0.bb
@@ -11,7 +11,7 @@ SRC_URI = "http://ftp.gnome.org/pub/GNOME/mobile/2.23/2.23.92/sources/evolution-
S = "${WORKDIR}/evolution-data-server-dbus-${PV}"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -20,10 +20,6 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
-do_stage () {
- autotools_stage_all
-}
-
EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
--with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
--disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
diff --git a/meta/packages/eds/eds-dbus_svn.bb b/meta/packages/eds/eds-dbus_svn.bb
index 81d9e83cf..83b875bd4 100644
--- a/meta/packages/eds/eds-dbus_svn.bb
+++ b/meta/packages/eds/eds-dbus_svn.bb
@@ -13,7 +13,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
S = "${WORKDIR}/trunk"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
@@ -22,10 +22,6 @@ do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
-do_stage () {
- autotools_stage_all
-}
-
EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
--with-soup --with-libdb=${STAGING_DIR_HOST}${layout_prefix} \
--disable-smime --disable-nss --disable-nntp --disable-gtk-doc"