summaryrefslogtreecommitdiff
path: root/meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-07 19:15:40 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 21:05:41 -0700
commit43bd7936793701839df4dd4e49ef91985ee11e06 (patch)
tree9e3da8c4025a0aec1b544a1f39ce8cf520e06795 /meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch
parent59df5a4b2dd2696f34c074d11b15ed18cc6bea65 (diff)
downloadopenembedded-core-43bd7936793701839df4dd4e49ef91985ee11e06.tar.gz
openembedded-core-43bd7936793701839df4dd4e49ef91985ee11e06.tar.bz2
openembedded-core-43bd7936793701839df4dd4e49ef91985ee11e06.tar.xz
openembedded-core-43bd7936793701839df4dd4e49ef91985ee11e06.zip
fakeroot: upgrade to 1.14.4
[Patches] KEEP _absolutepaths.patch_: solve python link issue REMOVE _configure-libtool.patch_: an old patch, not required now [Recipe] manually create build-aux since its own bootstrap contains more than we want Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch')
-rw-r--r--meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch b/meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch
new file mode 100644
index 000000000..ae18e8a28
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-1.14.4/absolutepaths.patch
@@ -0,0 +1,47 @@
+Image creation runs under a fakeroot context and calls a script which refers
+to the build systems's python. This loads but can find a libpython from staging
+if these are incompatible, anything can break. These scripts should *not* be
+changing LD_LIBRARY_PATH, just adding an LD_PRELOAD with an absolute path. The
+dyanmic linker can figure out anything else with rpaths.
+
+RP - 23/1/10
+
+Index: fakeroot-1.9.4/configure.ac
+===================================================================
+--- fakeroot-1.9.4.orig/configure.ac 2010-01-23 22:34:39.000000000 +0000
++++ fakeroot-1.9.4/configure.ac 2010-01-23 22:35:14.000000000 +0000
+@@ -414,6 +414,8 @@
+ ;;
+ esac
+
++LDPRELOADABS=1
++
+ AC_DEFINE_UNQUOTED([LIBCPATH], "$libcpath", [path to libc shared object])
+ AC_SUBST(DLSUFFIX)
+ AC_SUBST(LDLIBPATHVAR)
+Index: fakeroot-1.9.4/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.9.4.orig/scripts/fakeroot.in 2010-01-23 22:34:53.000000000 +0000
++++ fakeroot-1.9.4/scripts/fakeroot.in 2010-01-23 22:37:17.000000000 +0000
+@@ -135,7 +135,7 @@
+ if [ "$WAITINTRAP" -eq 0 ]; then
+ trap "kill -s @signal@ $PID" EXIT INT
+ else
+- trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
++ trap 'FAKEROOTKEY=$FAKEROOTKEY LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
+ fi
+
+ if test -z "$FAKEROOTKEY" || test -z "$PID"; then
+@@ -158,10 +158,10 @@
+ export FAKEROOT_FD_BASE
+
+ if test -z "$*"; then
+- FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
++ FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
+ RESULT=$?
+ else
+- FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
++ FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
+ RESULT=$?
+ fi
+