summaryrefslogtreecommitdiff
path: root/meta/packages/findutils/findutils_4.4.2.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-08 13:46:40 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 21:10:59 -0700
commit62136a869a56d4ad2b61fec2b8bbd23626433056 (patch)
treea97e878e8af65f9d231dd93b4bcbb24921fd9cea /meta/packages/findutils/findutils_4.4.2.bb
parent90ceeff2587c932f9d998ccf05f01c01300f3268 (diff)
downloadopenembedded-core-62136a869a56d4ad2b61fec2b8bbd23626433056.tar.gz
openembedded-core-62136a869a56d4ad2b61fec2b8bbd23626433056.tar.bz2
openembedded-core-62136a869a56d4ad2b61fec2b8bbd23626433056.tar.xz
openembedded-core-62136a869a56d4ad2b61fec2b8bbd23626433056.zip
findutils: upgrade to version 4.2.31 and 4.4.2
from 4.2.29 4.2.31 is the last known GPL2 version changes for 4.4: - pulled upstream patch to fix bug #27017, #28824 and #28872 - using a workaround to address bug #27299, this was fixed in development branch 4.5.3 by using a new version of gnulib. however, upgrading gnulib needs too much effort here. changes for 4.2: - 4.2.31's gnulib/m4/extension.m4 won't work with autoconf 2.65, fix it by removing gnulib's AC_USE_SYSTEM_EXTENSIONS Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/findutils/findutils_4.4.2.bb')
-rw-r--r--meta/packages/findutils/findutils_4.4.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/packages/findutils/findutils_4.4.2.bb b/meta/packages/findutils/findutils_4.4.2.bb
new file mode 100644
index 000000000..18514f36e
--- /dev/null
+++ b/meta/packages/findutils/findutils_4.4.2.bb
@@ -0,0 +1,27 @@
+require findutils.inc
+
+PR = "r0"
+
+SRC_URI += "file://01-27017.patch \
+ file://02-28824.patch \
+ file://03-28872.patch"
+
+# http://savannah.gnu.org/bugs/?27299
+EXTRA_OECONF += "gl_cv_func_wcwidth_works=yes"
+
+do_install_append () {
+ if [ -e ${D}${bindir}/find ]; then
+ mv ${D}${bindir}/find ${D}${bindir}/find.${PN}
+ mv ${D}${bindir}/xargs ${D}${bindir}/xargs.${PN}
+ fi
+}
+
+pkg_postinst_${PN} () {
+ for i in find xargs; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
+}
+
+pkg_prerm_${PN} () {
+ for i in find xargs; do update-alternatives --remove $i $i.${PN}; done
+}
+
+BBCLASSEXTEND = "native"