summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-28 21:49:10 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-28 21:49:10 +0000
commitdb99dabc6672e7378cee1068d1e488443d718923 (patch)
tree7ea259295cc872da404ada9deeb697f708097b5f /meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
parent23d8841f28c06497d7a66e90b0ce2a88601ce627 (diff)
downloadopenembedded-core-db99dabc6672e7378cee1068d1e488443d718923.tar.gz
openembedded-core-db99dabc6672e7378cee1068d1e488443d718923.tar.bz2
openembedded-core-db99dabc6672e7378cee1068d1e488443d718923.tar.xz
openembedded-core-db99dabc6672e7378cee1068d1e488443d718923.zip
gcc: Drop 4.3.1 and 4.3.2
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch b/meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
deleted file mode 100644
index a0c6acd9f..000000000
--- a/meta/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/sh -e
-
-# DP: GNU/k*BSD support
-# Author: Aurelien Jarno <aurel32@debian.org>
-# Status: Submitted: http://gcc.gnu.org/ml/gcc-patches/2007-04/msg01962.html
-
-dir=
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
- dir="$3/"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch)
- patch $pdir -f --no-backup-if-mismatch -p1 < $0
- ;;
- -unpatch)
- patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
- ;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
-# append the patch here and adjust the -p? flag in the patch calls.
-
---- src.orig/gcc/configure 2008-03-01 15:51:06 +0100
-+++ src/gcc/configure 2008-03-01 16:02:24 +0100
-@@ -17110,7 +17110,7 @@
- else
- gcc_cv_libc_provides_ssp=no
- case "$target" in
-- *-*-linux*)
-+ *-*-*-gnu*)
- if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
- if test "x$with_sysroot" = x; then
- glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
---- src.orig/gcc/configure.ac 2008-02-01 19:55:55 +0100
-+++ src/gcc/configure.ac 2008-03-01 16:02:06 +0100
-@@ -3379,7 +3379,7 @@
- gcc_cv_libc_provides_ssp,
- [gcc_cv_libc_provides_ssp=no
- case "$target" in
-- *-*-linux*)
-+ *-*-*-gnu*)
- if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
- if test "x$with_sysroot" = x; then
- glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
-