summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
commite6a3149428ef2d42d9a9df78a19c2e52496f3deb (patch)
tree368294cd96f741990717234a6819cc60c1b413f6 /meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch
parentf887fcd665505453412a9f2e2508404e6ec4eea8 (diff)
downloadopenembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.gz
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.bz2
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.xz
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.zip
gcc: Add 4.3.3 and switch to for Moblin
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch b/meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch
new file mode 100644
index 000000000..c2622903e
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.3/debian/cross-include.dpatch
@@ -0,0 +1,39 @@
+#! /bin/sh -e
+
+# DP: Set cross include path to .../include, not .../sys-include
+# DP: This should be a fix for famous limits.h issue
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ cd ${dir}gcc && autoconf
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ cd ${dir}gcc && autoconf
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- gcc/configure.ac.orig 2005-08-24 06:24:11.000000000 +0400
++++ gcc/configure.ac 2005-12-06 00:40:45.000000000 +0300
+@@ -681,7 +681,7 @@
+ ], [
+ TARGET_SYSTEM_ROOT=
+ TARGET_SYSTEM_ROOT_DEFINE=
+- CROSS_SYSTEM_HEADER_DIR='$(gcc_tooldir)/sys-include'
++ CROSS_SYSTEM_HEADER_DIR='$(prefix)/$(target_noncanonical)/include'
+ ])
+ AC_SUBST(TARGET_SYSTEM_ROOT)
+ AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)