summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-06-09 12:50:17 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-09 12:50:17 +0100
commit3ff78923ba9f8aa05dd3ca8e779e675b457efffa (patch)
treedb930da8c03cbc82171fe3bbc8262bce9c7cbdc8 /meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
parentc2569a74052ee7ba840e0bc34591ce8a23800688 (diff)
downloadopenembedded-core-3ff78923ba9f8aa05dd3ca8e779e675b457efffa.tar.gz
openembedded-core-3ff78923ba9f8aa05dd3ca8e779e675b457efffa.tar.bz2
openembedded-core-3ff78923ba9f8aa05dd3ca8e779e675b457efffa.tar.xz
openembedded-core-3ff78923ba9f8aa05dd3ca8e779e675b457efffa.zip
gcc-4.3.3: Drop unused patches
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch')
-rw-r--r--meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch47
1 files changed, 0 insertions, 47 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch b/meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
deleted file mode 100644
index f86ee0994..000000000
--- a/meta/packages/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
+++ /dev/null
@@ -1,47 +0,0 @@
-#! /bin/sh -e
-
-# DP: build protoize/unprotoize binaries
-
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch) patch $pdir -f --no-backup-if-mismatch -p0 < $0;;
- -unpatch) patch $pdir -f --no-backup-if-mismatch -R -p0 < $0;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
---- gcc/Makefile.in.orig 2007-09-06 21:31:39.864036975 +0200
-+++ gcc/Makefile.in 2007-09-06 21:33:57.836118252 +0200
-@@ -137,7 +137,7 @@
-
- # Selection of languages to be made.
- CONFIG_LANGUAGES = @all_selected_languages@
--LANGUAGES = c gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
-+LANGUAGES = c proto gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
-
- # Various ways of specifying flags for compilations:
- # CFLAGS is for the user to override to, e.g., do a cross build with -O2.
-@@ -3280,14 +3280,14 @@
- protoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) $(SYSTEM_H) \
- coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
- (SHLIB_LINK='$(SHLIB_LINK)'; \
-- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
-+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
- $(DRIVER_DEFINES) \
- $(srcdir)/protoize.c $(OUTPUT_OPTION))
-
- unprotoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) \
- $(SYSTEM_H) coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
- (SHLIB_LINK='$(SHLIB_LINK)'; \
-- $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
-+ $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
- $(DRIVER_DEFINES) \
- $(srcdir)/protoize.c $(OUTPUT_OPTION))
-