summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
commite6a3149428ef2d42d9a9df78a19c2e52496f3deb (patch)
tree368294cd96f741990717234a6819cc60c1b413f6 /meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch
parentf887fcd665505453412a9f2e2508404e6ec4eea8 (diff)
downloadopenembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.gz
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.bz2
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.xz
openembedded-core-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.zip
gcc: Add 4.3.3 and switch to for Moblin
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch')
-rw-r--r--meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch b/meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch
new file mode 100644
index 000000000..b3d38ad98
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.3/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets