summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-19 02:36:13 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 01:38:36 +0100
commitc7c5c34188599bae19991f842a836fe125fa3283 (patch)
tree5e2e97d48c73cc9d0206a0d57bf2446b8dec8af1 /meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch
parent722e27e44806558b2ef3e6b7072451981fa5823e (diff)
downloadopenembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.gz
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.bz2
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.xz
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.zip
gcc family : upgrade to 4.5.0
Imported OE patches into the poky recipes. - Use elfutils instead of libelf Converted OE's svn source into tar ball & a patch. Added a patch to revert the baseversion to 4.5.0 Merge OE & poky extra_oeconf_options Fix the zlib (inside gcc) make issue by providing the --with-system-zlib switch in EXTRA_OECONF Found out that some header file dirs were soft linked to non-existing locations like c_std. Changed the configure options to point them to existing locations like c_global. gcc-cross-canadian_4.5.0: fix configure issue Thanks to Saul Wold for providing poky gcc patches rebased to the 4.5.0 sources. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch')
-rw-r--r--meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch b/meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch
new file mode 100644
index 000000000..23fce7544
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.5.0/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,20 @@
+--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
+@@ -21,5 +21,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
++++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
+@@ -35,7 +35,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC