summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-19 02:36:13 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 01:38:36 +0100
commitc7c5c34188599bae19991f842a836fe125fa3283 (patch)
tree5e2e97d48c73cc9d0206a0d57bf2446b8dec8af1 /meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch
parent722e27e44806558b2ef3e6b7072451981fa5823e (diff)
downloadopenembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.gz
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.bz2
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.tar.xz
openembedded-core-c7c5c34188599bae19991f842a836fe125fa3283.zip
gcc family : upgrade to 4.5.0
Imported OE patches into the poky recipes. - Use elfutils instead of libelf Converted OE's svn source into tar ball & a patch. Added a patch to revert the baseversion to 4.5.0 Merge OE & poky extra_oeconf_options Fix the zlib (inside gcc) make issue by providing the --with-system-zlib switch in EXTRA_OECONF Found out that some header file dirs were soft linked to non-existing locations like c_std. Changed the configure options to point them to existing locations like c_global. gcc-cross-canadian_4.5.0: fix configure issue Thanks to Saul Wold for providing poky gcc patches rebased to the 4.5.0 sources. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch')
-rw-r--r--meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch b/meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch
new file mode 100644
index 000000000..b889f9b6c
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.5.0/cache-amnesia.patch
@@ -0,0 +1,31 @@
+---
+ gcc/configure | 2 +-
+ gcc/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: gcc-4.5+svnr155514/gcc/configure
+===================================================================
+--- gcc-4.5+svnr155514.orig/gcc/configure 2009-12-29 22:00:40.000000000 -0800
++++ gcc-4.5+svnr155514/gcc/configure 2009-12-29 23:52:43.381592113 -0800
+@@ -10467,7 +10467,7 @@ else
+ saved_CFLAGS="${CFLAGS}"
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+ LDFLAGS="${LDFLAGS_FOR_BUILD}" \
+- ${realsrcdir}/configure \
++ CONFIG_SITE= ${realsrcdir}/configure --cache-file=./other.cache \
+ --enable-languages=${enable_languages-all} \
+ --target=$target_alias --host=$build_alias --build=$build_alias
+ CFLAGS="${saved_CFLAGS}"
+Index: gcc-4.5+svnr155514/gcc/configure.ac
+===================================================================
+--- gcc-4.5+svnr155514.orig/gcc/configure.ac 2009-12-29 22:00:40.000000000 -0800
++++ gcc-4.5+svnr155514/gcc/configure.ac 2009-12-29 23:51:54.589091778 -0800
+@@ -1458,7 +1458,7 @@ else
+ saved_CFLAGS="${CFLAGS}"
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+ LDFLAGS="${LDFLAGS_FOR_BUILD}" \
+- ${realsrcdir}/configure \
++ CONFIG_SITE= ${realsrcdir}/configure --cache-file=./other.cache \
+ --enable-languages=${enable_languages-all} \
+ --target=$target_alias --host=$build_alias --build=$build_alias
+ CFLAGS="${saved_CFLAGS}"