summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-cross_4.2.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-04 16:33:10 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-04 16:33:10 +0000
commit4c117c12857ff176faee157b49250e0a12895de7 (patch)
tree92839f106628019c1edafdf88a2e98fcaadcc1b8 /meta/packages/gcc/gcc-cross_4.2.2.bb
parente14e1e23c42f61c40b3686c49907ea16fa4004a6 (diff)
downloadopenembedded-core-4c117c12857ff176faee157b49250e0a12895de7.tar.gz
openembedded-core-4c117c12857ff176faee157b49250e0a12895de7.tar.bz2
openembedded-core-4c117c12857ff176faee157b49250e0a12895de7.tar.xz
openembedded-core-4c117c12857ff176faee157b49250e0a12895de7.zip
gcc: added 4.2.2 from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3902 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc-cross_4.2.2.bb')
-rw-r--r--meta/packages/gcc/gcc-cross_4.2.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-cross_4.2.2.bb b/meta/packages/gcc/gcc-cross_4.2.2.bb
new file mode 100644
index 000000000..def16597e
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross_4.2.2.bb
@@ -0,0 +1,22 @@
+require gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r6"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+# Do not build libssp libmudflap and libgomp
+# We might need them for some beefy targets
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"