summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc_4.1.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-08-26 22:58:50 +0000
committerRichard Purdie <richard@openedhand.com>2006-08-26 22:58:50 +0000
commit8800d8be25295dd7c7d84dde62c3be4df8e43346 (patch)
tree8ec8b868f4dc4ba56c74d1f7de0bb45ecb80664a /meta/packages/gcc/gcc_4.1.1.bb
parent1562178b03be74528c52f70228d13ea257c2d445 (diff)
downloadopenembedded-core-8800d8be25295dd7c7d84dde62c3be4df8e43346.tar.gz
openembedded-core-8800d8be25295dd7c7d84dde62c3be4df8e43346.tar.bz2
openembedded-core-8800d8be25295dd7c7d84dde62c3be4df8e43346.tar.xz
openembedded-core-8800d8be25295dd7c7d84dde62c3be4df8e43346.zip
gcc: Add 4.1.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@648 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.1.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc_4.1.1.bb b/meta/packages/gcc/gcc_4.1.1.bb
new file mode 100644
index 000000000..e2d3d25ea
--- /dev/null
+++ b/meta/packages/gcc/gcc_4.1.1.bb
@@ -0,0 +1,47 @@
+PR = "r6"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+require gcc-package.inc
+
+SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
+ file://100-uclibc-conf.patch;patch=1 \
+ file://110-arm-eabi.patch;patch=1 \
+ file://200-uclibc-locale.patch;patch=1 \
+ file://300-libstdc++-pic.patch;patch=1 \
+ file://301-missing-execinfo_h.patch;patch=1 \
+ file://302-c99-snprintf.patch;patch=1 \
+ file://303-c99-complex-ugly-hack.patch;patch=1 \
+ file://304-index_macro.patch;patch=1 \
+ file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://740-sh-pr24836.patch;patch=1 \
+ file://800-arm-bigendian.patch;patch=1 \
+ file://arm-nolibfloat.patch;patch=1 \
+ file://arm-softfloat.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://arm-thumb.patch;patch=1 \
+ file://arm-thumb-cache.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://cse.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+#Set the fortran bits
+FORTRAN = ""
+HAS_GFORTRAN = "no"
+HAS_G2C = "no"
+
+#Set the java bits
+JAVA_arm = ""
+
+LANGUAGES = "c,c++"
+require gcc3-build.inc
+
+
+EXTRA_OECONF += " --disable-libssp "
+