summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-18 10:41:39 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-18 10:41:39 +0000
commit1255ee64ee58fb5f0acd0bdbf4f0a54afd5ceeaf (patch)
tree293d34ede70b906b04967ac077e32a8fee4e855b /meta/packages/gcc/gcc_4.1.2.bb
parent402c7dcb2790bd51de9436befe8c273e538be441 (diff)
downloadopenembedded-core-1255ee64ee58fb5f0acd0bdbf4f0a54afd5ceeaf.tar.gz
openembedded-core-1255ee64ee58fb5f0acd0bdbf4f0a54afd5ceeaf.tar.bz2
openembedded-core-1255ee64ee58fb5f0acd0bdbf4f0a54afd5ceeaf.tar.xz
openembedded-core-1255ee64ee58fb5f0acd0bdbf4f0a54afd5ceeaf.zip
gcc: Merge in the major cleanup I made in OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4038 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.2.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.2.bb57
1 files changed, 5 insertions, 52 deletions
diff --git a/meta/packages/gcc/gcc_4.1.2.bb b/meta/packages/gcc/gcc_4.1.2.bb
index c4a124081..c51eb23b0 100644
--- a/meta/packages/gcc/gcc_4.1.2.bb
+++ b/meta/packages/gcc/gcc_4.1.2.bb
@@ -1,54 +1,7 @@
-PR = "r3"
-DESCRIPTION = "The GNU cc and gcc C compilers."
-HOMEPAGE = "http://www.gnu.org/software/gcc/"
-SECTION = "devel"
-LICENSE = "GPL"
+PR = "r11"
-ARM_INSTRUCTION_SET = "arm"
-
-inherit autotools gettext
-
-require gcc-package.inc
-
-SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- "
-
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
-
-#Set the fortran bits
-# 'fortran' or '', not 'f77' like gcc3 had
-FORTRAN = ""
-HAS_GFORTRAN = "no"
-HAS_G2C = "no"
-
-#Set the java bits
-JAVA_arm = ""
-JAVA = ""
-
-LANGUAGES = "c,c++${FORTRAN}${JAVA}"
-require gcc3-build.inc
-
-
-EXTRA_OECONF += " --disable-libssp "
+require gcc-${PV}.inc
+require gcc-configure-target.inc
+require gcc-package-target.inc
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"