summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-05-27 21:11:04 +0000
committerRichard Purdie <richard@openedhand.com>2007-05-27 21:11:04 +0000
commit3a11c9d58f56fed153c79521fb052fe3474e02ad (patch)
treed0d85b9276c74ab23b869da66cdd046df9ad6da4 /meta/packages/gcc/gcc_4.1.2.bb
parent32275ea450a65e31c10c84b76142d92e15d64ee7 (diff)
downloadopenembedded-core-3a11c9d58f56fed153c79521fb052fe3474e02ad.tar.gz
openembedded-core-3a11c9d58f56fed153c79521fb052fe3474e02ad.tar.bz2
openembedded-core-3a11c9d58f56fed153c79521fb052fe3474e02ad.tar.xz
openembedded-core-3a11c9d58f56fed153c79521fb052fe3474e02ad.zip
gcc: Sync 4.1.1, add 4.1.2 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1787 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc_4.1.2.bb')
-rw-r--r--meta/packages/gcc/gcc_4.1.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc_4.1.2.bb b/meta/packages/gcc/gcc_4.1.2.bb
new file mode 100644
index 000000000..417909eb1
--- /dev/null
+++ b/meta/packages/gcc/gcc_4.1.2.bb
@@ -0,0 +1,51 @@
+PR = "r3"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+require gcc-package.inc
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
+ file://100-uclibc-conf.patch;patch=1 \
+ file://110-arm-eabi.patch;patch=1 \
+ file://200-uclibc-locale.patch;patch=1 \
+ file://300-libstdc++-pic.patch;patch=1 \
+ file://301-missing-execinfo_h.patch;patch=1 \
+ file://302-c99-snprintf.patch;patch=1 \
+ file://303-c99-complex-ugly-hack.patch;patch=1 \
+ file://304-index_macro.patch;patch=1 \
+ file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://740-sh-pr24836.patch;patch=1 \
+ file://800-arm-bigendian.patch;patch=1 \
+ file://arm-nolibfloat.patch;patch=1 \
+ file://arm-softfloat.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://arm-thumb.patch;patch=1 \
+ file://arm-thumb-cache.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
+ file://unbreak-armv4t.patch;patch=1 \
+ file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
+ "
+
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+
+#Set the fortran bits
+# 'fortran' or '', not 'f77' like gcc3 had
+FORTRAN = ""
+HAS_GFORTRAN = "no"
+HAS_G2C = "no"
+
+#Set the java bits
+JAVA_arm = ""
+JAVA = ""
+
+LANGUAGES = "c,c++${FORTRAN}${JAVA}"
+require gcc3-build.inc
+
+
+EXTRA_OECONF += " --disable-libssp "
+