summaryrefslogtreecommitdiff
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-24 21:28:38 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-24 21:28:38 +0000
commitc673a12162ed112edea7c97141946d2b88152c3a (patch)
treef749cfd454c7057aa58a33d155d13d4e64921f7e /meta/packages/gcc
parentdc87a5f8219b5769ae971399b4c3335249849be4 (diff)
downloadopenembedded-core-c673a12162ed112edea7c97141946d2b88152c3a.tar.gz
openembedded-core-c673a12162ed112edea7c97141946d2b88152c3a.tar.bz2
openembedded-core-c673a12162ed112edea7c97141946d2b88152c3a.tar.xz
openembedded-core-c673a12162ed112edea7c97141946d2b88152c3a.zip
gcc: Remove 3.4.3 and 4.1.1, add missing sdk 3.4.4 and initial 4.1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3591 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-cross-initial_3.4.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-initial_4.1.1.bb5
-rw-r--r--meta/packages/gcc/gcc-cross-sdk_4.1.1.bb40
-rw-r--r--meta/packages/gcc/gcc-cross_3.4.3.bb16
-rw-r--r--meta/packages/gcc/gcc-cross_4.1.1.bb18
-rw-r--r--meta/packages/gcc/gcc_3.4.3.bb26
-rw-r--r--meta/packages/gcc/gcc_4.1.1.bb61
7 files changed, 0 insertions, 168 deletions
diff --git a/meta/packages/gcc/gcc-cross-initial_3.4.3.bb b/meta/packages/gcc/gcc-cross-initial_3.4.3.bb
deleted file mode 100644
index 163951136..000000000
--- a/meta/packages/gcc/gcc-cross-initial_3.4.3.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require gcc-cross_${PV}.bb
-require gcc-cross-initial.inc
diff --git a/meta/packages/gcc/gcc-cross-initial_4.1.1.bb b/meta/packages/gcc/gcc-cross-initial_4.1.1.bb
deleted file mode 100644
index 1c1d09438..000000000
--- a/meta/packages/gcc/gcc-cross-initial_4.1.1.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require gcc-cross_${PV}.bb
-require gcc-cross-initial.inc
-
-EXTRA_OECONF += "--disable-libmudflap \
- --disable-libssp"
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb
deleted file mode 100644
index a59a43553..000000000
--- a/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-DESCRIPTION = "The GNU cc and gcc C compilers."
-require gcc_${PV}.bb
-PR = "r2"
-
-EXCLUDE_FROM_SHLIBS = "1"
-
-inherit sdk
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
-PACKAGES = "${PN}"
-
-require gcc4-build-sdk.inc
-require gcc-package-sdk.inc
-
-SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://cse.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://gcc-4.1.1-pr13685-1.patch;patch=1 \
- file://gcc-ignore-cache.patch;patch=1 \
- file://zecke-no-host-includes.patch;patch=1"
diff --git a/meta/packages/gcc/gcc-cross_3.4.3.bb b/meta/packages/gcc/gcc-cross_3.4.3.bb
deleted file mode 100644
index b61223b39..000000000
--- a/meta/packages/gcc/gcc-cross_3.4.3.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-require gcc_${PV}.bb
-# path mangling, needed by the cross packaging
-require gcc-paths-cross.inc
-inherit cross
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-# NOTE: split PR. If the main .oe changes something that affects its *build*
-# remember to increment this one too.
-PR = "r10"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
-
-# cross build
-require gcc3-build-cross.inc
-# cross packaging
-require gcc-package-cross.inc
diff --git a/meta/packages/gcc/gcc-cross_4.1.1.bb b/meta/packages/gcc/gcc-cross_4.1.1.bb
deleted file mode 100644
index 2d6cb1996..000000000
--- a/meta/packages/gcc/gcc-cross_4.1.1.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-require gcc_${PV}.bb
-# path mangling, needed by the cross packaging
-require gcc-paths-cross.inc
-inherit cross
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-# NOTE: split PR. If the main .oe changes something that affects its *build*
-# remember to increment this one too.
-PR = "r12"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
-
-# cross build
-require gcc3-build-cross.inc
-# cross packaging
-require gcc-package-cross.inc
-
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
diff --git a/meta/packages/gcc/gcc_3.4.3.bb b/meta/packages/gcc/gcc_3.4.3.bb
deleted file mode 100644
index 289fe8fdd..000000000
--- a/meta/packages/gcc/gcc_3.4.3.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-PR = "r11"
-DESCRIPTION = "The GNU cc and gcc C compilers."
-HOMEPAGE = "http://www.gnu.org/software/gcc/"
-SECTION = "devel"
-LICENSE = "GPL"
-
-inherit autotools gettext
-
-require gcc-package.inc
-
-SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
- file://gcc34-reverse-compare.patch;patch=1 \
- file://gcc34-arm-ldm.patch;patch=1 \
- file://gcc34-arm-ldm-peephole.patch;patch=1 \
- file://gcc34-arm-tune.patch;patch=1 \
- file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
- file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
- file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
- file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
- file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
- file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \
- file://GCC3.4.0VisibilityPatch.diff;patch=1 \
- file://15342.patch;patch=1 \
- file://always-fixincperm.patch;patch=1"
-
-require gcc3-build.inc
diff --git a/meta/packages/gcc/gcc_4.1.1.bb b/meta/packages/gcc/gcc_4.1.1.bb
deleted file mode 100644
index 9135daca1..000000000
--- a/meta/packages/gcc/gcc_4.1.1.bb
+++ /dev/null
@@ -1,61 +0,0 @@
-PR = "r14"
-DESCRIPTION = "The GNU cc and gcc C compilers."
-HOMEPAGE = "http://www.gnu.org/software/gcc/"
-SECTION = "devel"
-LICENSE = "GPL"
-
-inherit autotools gettext
-
-require gcc-package.inc
-
-SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://801-arm-bigendian-eabi.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://cse.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://gcc-4.1.1-pr13685-1.patch;patch=1 \
- file://gcc-ignore-cache.patch;patch=1 \
- "
-
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
-
-#This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc
-#the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc
-SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \
- file://ppc-sfp-long-double-gcc411-7.patch;patch=1 "
-
-
-#Set the fortran bits
-# 'fortran' or '', not 'f77' like gcc3 had
-FORTRAN = ""
-HAS_GFORTRAN = "no"
-HAS_G2C = "no"
-
-#Set the java bits
-JAVA_arm = ""
-JAVA = ""
-
-LANGUAGES = "c,c++${FORTRAN}${JAVA}"
-require gcc3-build.inc
-
-
-EXTRA_OECONF += " --disable-libssp "
-