summaryrefslogtreecommitdiff
path: root/meta/packages/gnutls
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/packages/gnutls
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.bz2
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.xz
openembedded-core-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.zip
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gnutls')
-rw-r--r--meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch64
-rw-r--r--meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch124
-rw-r--r--meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch16
-rw-r--r--meta/packages/gnutls/gnutls.inc44
-rw-r--r--meta/packages/gnutls/gnutls_2.8.6.bb7
-rw-r--r--meta/packages/gnutls/libtasn1_2.7.bb21
6 files changed, 0 insertions, 276 deletions
diff --git a/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch b/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch
deleted file mode 100644
index 247e32456..000000000
--- a/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-rebased from original configure_madness.patch
-
-libtasn1 provides an .pc file in upstream,
-and a libgcrypt.pc is added in libgcrypt recipe,
-so use Requires.private for these two.
-
-against 2.8.6
-
-07/02/2010 - qhe
-
----
-diff --git a/lib/configure.ac b/lib/configure.ac
-index 80d3375..1a486f7 100644
---- a/lib/configure.ac
-+++ b/lib/configure.ac
-@@ -81,8 +81,8 @@ fi
-
- lgl_INIT
-
--LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS"
--LIBGNUTLS_CFLAGS="-I${includedir}"
-+LIBGNUTLS_LIBS="-lgnutls $LIBS"
-+LIBGNUTLS_CFLAGS=""
- AC_SUBST(LIBGNUTLS_LIBS)
- AC_SUBST(LIBGNUTLS_CFLAGS)
-
-diff --git a/lib/gnutls.pc.in b/lib/gnutls.pc.in
-index 3b01c17..de31469 100644
---- a/lib/gnutls.pc.in
-+++ b/lib/gnutls.pc.in
-@@ -20,6 +20,6 @@ Name: GnuTLS
- Description: Transport Security Layer implementation for the GNU system
- URL: http://www.gnu.org/software/gnutls/
- Version: @VERSION@
-+Requires.private: libgcrypt, libtasn1
- Libs: -L${libdir} -lgnutls
--Libs.private: @LIBGNUTLS_LIBS@ @LTLIBTASN1@
- Cflags: -I${includedir}
-diff --git a/libextra/configure.ac b/libextra/configure.ac
-index c08e73f..3313886 100644
---- a/libextra/configure.ac
-+++ b/libextra/configure.ac
-@@ -40,8 +40,8 @@ LIBGNUTLS_EXTRA_HOOKS
-
- xgl_INIT
-
--LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
--LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}"
-+LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS"
-+LIBGNUTLS_EXTRA_CFLAGS=""
- AC_SUBST(LIBGNUTLS_EXTRA_LIBS)
- AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS)
-
-diff --git a/libextra/gnutls-extra.pc.in b/libextra/gnutls-extra.pc.in
-index 9e7b8f6..e228ec9 100644
---- a/libextra/gnutls-extra.pc.in
-+++ b/libextra/gnutls-extra.pc.in
-@@ -21,5 +21,5 @@ URL: http://www.gnu.org/software/gnutls/
- Requires: gnutls
- Version: @VERSION@
- Libs: -L${libdir} -lgnutls-extra
--Libs.private: @LIBGNUTLS_EXTRA_LIBS@
-+Libs.private: -llzo2
- Cflags: -I${includedir}
diff --git a/meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch b/meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch
deleted file mode 100644
index 413de0647..000000000
--- a/meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-Index: gnutls-1.6.0/libextra/gnutls_openssl.c
-===================================================================
---- gnutls-1.6.0.orig/libextra/gnutls_openssl.c 2006-08-13 22:34:09.000000000 +0200
-+++ gnutls-1.6.0/libextra/gnutls_openssl.c 2006-12-12 15:07:59.002227000 +0100
-@@ -256,12 +256,17 @@
- ssl->rfd = (gnutls_transport_ptr_t) - 1;
- ssl->wfd = (gnutls_transport_ptr_t) - 1;
-
-+ ssl->ssl_peek_buffer = NULL;
-+ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
-+
- return ssl;
- }
-
- void
- SSL_free (SSL * ssl)
- {
-+ if (ssl->ssl_peek_buffer)
-+ free(ssl->ssl_peek_buffer);
- gnutls_certificate_free_credentials (ssl->gnutls_cred);
- gnutls_deinit (ssl->gnutls_state);
- free (ssl);
-@@ -285,6 +290,7 @@
- SSL_set_fd (SSL * ssl, int fd)
- {
- gnutls_transport_set_ptr (ssl->gnutls_state, GNUTLS_INT_TO_POINTER (fd));
-+ ssl->rfd = ssl->wfd = fd;
- return 1;
- }
-
-@@ -310,6 +316,17 @@
- return 1;
- }
-
-+int SSL_get_rfd(SSL *ssl)
-+{
-+ return ssl->rfd;
-+}
-+
-+int SSL_get_wfd(SSL *ssl)
-+{
-+ return ssl->wfd;
-+}
-+
-+
- void
- SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
- {
-@@ -325,6 +342,8 @@
- int
- SSL_pending (SSL * ssl)
- {
-+ if (ssl->ssl_peek_avail)
-+ return ssl->ssl_peek_avail;
- return gnutls_record_check_pending (ssl->gnutls_state);
- }
-
-@@ -480,11 +499,50 @@
- return 1;
- }
-
-+int SSL_peek(SSL *ssl, void *buf, int len)
-+{
-+ if (len > ssl->ssl_peek_buffer_size) {
-+ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
-+ ssl->ssl_peek_buffer_size = len;
-+ }
-+
-+ if (ssl->ssl_peek_avail == 0) {
-+
-+ int ret;
-+
-+ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
-+ ssl->last_error = ret;
-+
-+ if (ret > 0)
-+ ssl->ssl_peek_avail += ret;
-+ }
-+
-+ if (len > ssl->ssl_peek_avail)
-+ len = ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, len);
-+
-+ return len;
-+}
-+
- int
- SSL_read (SSL * ssl, void *buf, int len)
- {
- int ret;
-
-+ if (ssl->ssl_peek_avail) {
-+ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
-+
-+ memcpy (buf, ssl->ssl_peek_buffer, n);
-+
-+ if (ssl->ssl_peek_avail > n)
-+ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
-+
-+ ssl->ssl_peek_avail -= n;
-+
-+ return n;
-+ }
-+
- ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
- ssl->last_error = ret;
-
-Index: gnutls-1.6.0/includes/gnutls/openssl.h
-===================================================================
---- gnutls-1.6.0.orig/libextra/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100
-+++ gnutls-1.6.0/libextra/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100
-@@ -164,6 +164,11 @@
-
- gnutls_transport_ptr_t rfd;
- gnutls_transport_ptr_t wfd;
-+
-+ char *ssl_peek_buffer;
-+ size_t ssl_peek_buffer_size;
-+ size_t ssl_peek_avail;
-+
- };
-
- #define rbio gnutls_state
diff --git a/meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch b/meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch
deleted file mode 100644
index a2d2f0387..000000000
--- a/meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The version of texinfo in Debian Sarge does not understand the @euro{} command.
-This patch replaces the @euro{} command with the word "euro".
-
---- gnutls-1.3.5/doc/gnutls.texi.orig 2006-04-26 08:06:40.918268000 +0930
-+++ gnutls-1.3.5/doc/gnutls.texi 2006-04-26 08:06:52.446515440 +0930
-@@ -11,8 +11,8 @@
- long as it is difficult enough to generate two different messages with
- the same hash algorithm output. In that case the same signature could
- be used as a proof for both messages. Nobody wants to sign an innocent
--message of donating 1 @euro{} to Greenpeace and find out that he
--donated 1.000.000 @euro{} to Bad Inc.
-+message of donating 1 euro to Greenpeace and find out that he
-+donated 1.000.000 euro to Bad Inc.
-
- For a hash algorithm to be called cryptographic the following three
- requirements must hold
diff --git a/meta/packages/gnutls/gnutls.inc b/meta/packages/gnutls/gnutls.inc
deleted file mode 100644
index 76f4ca63f..000000000
--- a/meta/packages/gnutls/gnutls.inc
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "GNU Transport Layer Security Library"
-HOMEPAGE = "http://www.gnu.org/software/gnutls/"
-BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
-DEPENDS = "zlib lzo gettext libtasn1 libgcrypt (>= 1.4.2)"
-
-LICENSE = "GPLv3+ & LGPLv2.1+"
-LICENSE_${PN} = "LGPLv2.1+"
-LICENSE_${PN}-xx = "GPLv2.1+"
-LICENSE_${PN}-bin = "GPLv3+"
-LICENSE_${PN}-extra = "GPLv3+"
-LICENSE_${PN}-openssl = "GPLv3+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- file://lib/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://libextra/COPYING;md5=d32239bcb673463ab874e80d47fae504"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2"
-
-inherit autotools binconfig pkgconfig
-
-EXTRA_OECONF="--with-included-opencdk --with-included-libcfg --disable-rpath \
- --with-libtasn1-prefix=${STAGING_DIR_HOST}${prefix} \
- --with-libgcrypt-prefix=${STAGING_DIR_HOST}${prefix} \
- --with-libz-prefix=${STAGING_DIR_HOST}${prefix} --with-lzo --disable-guile"
-
-do_configure_prepend() {
- for dir in . lib libextra; do
- rm ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
- done
-}
-
-PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin ${PN}-xx"
-
-FILES_${PN} = "${libdir}/libgnutls.so.*"
-FILES_${PN}-bin = "${bindir}/gnutls-serv \
- ${bindir}/gnutls-cli \
- ${bindir}/srptool \
- ${bindir}/psktool \
- ${bindir}/certtool \
- ${bindir}/gnutls-srpcrypt"
-
-FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
-FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
-FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
-FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
diff --git a/meta/packages/gnutls/gnutls_2.8.6.bb b/meta/packages/gnutls/gnutls_2.8.6.bb
deleted file mode 100644
index d8adc6ba1..000000000
--- a/meta/packages/gnutls/gnutls_2.8.6.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require gnutls.inc
-
-PR = "r0"
-
-SRC_URI += "file://gnutls-openssl.patch \
- file://gnutls-texinfo-euro.patch \
- file://configure-fix.patch"
diff --git a/meta/packages/gnutls/libtasn1_2.7.bb b/meta/packages/gnutls/libtasn1_2.7.bb
deleted file mode 100644
index 11a7dc505..000000000
--- a/meta/packages/gnutls/libtasn1_2.7.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "Library for ASN.1 and DER manipulation"
-HOMEPAGE = "http://www.gnu.org/software/libtasn1/"
-
-LICENSE = "GPLv3+ & LGPLv2.1+"
-LICENSE_${PN}-bin = "GPLv3+"
-LICENSE_${PN} = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
- file://README;endline=8;md5=c3803a3e8ca5ab5eb1e5912faa405351"
-
-RREPLACES_${PN}-bin = "libtasn1 (<< 2.7)"
-
-PR = "r0"
-
-SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/libtasn1/libtasn1-${PV}.tar.gz"
-
-inherit autotools binconfig lib_package
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-BBCLASSEXTEND = "native"