summaryrefslogtreecommitdiff
path: root/meta/packages/gstreamer/gstreamer-0.10.17
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-01-30 15:22:55 +0000
committerRoss Burton <ross@openedhand.com>2008-01-30 15:22:55 +0000
commitd1a924f725616ae1afd4c7640668eec20a3a31b5 (patch)
tree5bdf27e36b81aa53c5b9959c965310db6c735c1a /meta/packages/gstreamer/gstreamer-0.10.17
parent7b8c36626b4ba18a355df6689ae25a594f3fb77f (diff)
downloadopenembedded-core-d1a924f725616ae1afd4c7640668eec20a3a31b5.tar.gz
openembedded-core-d1a924f725616ae1afd4c7640668eec20a3a31b5.tar.bz2
openembedded-core-d1a924f725616ae1afd4c7640668eec20a3a31b5.tar.xz
openembedded-core-d1a924f725616ae1afd4c7640668eec20a3a31b5.zip
gstreamer: update to latest upstream, fix doesn't effect us bit it doesn't hurt to be current
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3624 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gstreamer/gstreamer-0.10.17')
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch11
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch65
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch24
3 files changed, 100 insertions, 0 deletions
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch b/meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch
new file mode 100644
index 000000000..5da6cdd9c
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch
@@ -0,0 +1,11 @@
+--- gstreamer-0.10.9/tools/gst-inspect.c.old 2006-09-12 11:56:53.000000000 +0100
++++ gstreamer-0.10.9/tools/gst-inspect.c 2006-09-12 11:57:27.000000000 +0100
+@@ -1123,7 +1123,7 @@
+ g_option_context_add_main_entries (ctx, options, GETTEXT_PACKAGE);
+ g_option_context_add_group (ctx, gst_init_get_option_group ());
+ if (!g_option_context_parse (ctx, &argc, &argv, &err)) {
+- g_print ("Error initializing: %s\n", err->message);
++ g_print ("Error initializing: %s\n", err ? err->message : "(null)");
+ exit (1);
+ }
+ g_option_context_free (ctx);
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch
new file mode 100644
index 000000000..e166fc37e
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch
@@ -0,0 +1,65 @@
+diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c gstreamer-0.10.9/gst/gst.c
+--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c 2006-07-11 21:16:04.000000000 +0100
++++ gstreamer-0.10.9/gst/gst.c 2006-09-01 12:30:36.000000000 +0100
+@@ -553,7 +553,7 @@
+ GList *l;
+
+ GST_DEBUG ("reading registry cache: %s", registry_file);
+- gst_registry_xml_read_cache (default_registry, registry_file);
++ gst_registry_binary_read_cache (default_registry, registry_file);
+
+ /* scan paths specified via --gst-plugin-path */
+ GST_DEBUG ("scanning paths added via --gst-plugin-path");
+@@ -624,7 +624,7 @@
+ }
+
+ GST_DEBUG ("writing registry cache");
+- if (!gst_registry_xml_write_cache (default_registry, registry_file)) {
++ if (!gst_registry_binary_write_cache (default_registry, registry_file)) {
+ g_warning ("Problem writing registry cache to %s: %s", registry_file,
+ g_strerror (errno));
+ return FALSE;
+@@ -700,7 +700,7 @@
+
+ if (WEXITSTATUS (status) == EXIT_SUCCESS) {
+ GST_DEBUG ("parent reading registry cache");
+- gst_registry_xml_read_cache (default_registry, registry_file);
++ gst_registry_binary_read_cache (default_registry, registry_file);
+ } else {
+ GST_DEBUG ("parent re-scanning registry");
+ scan_and_update_registry (default_registry, registry_file, FALSE);
+@@ -722,7 +722,7 @@
+ registry_file = g_strdup (g_getenv ("GST_REGISTRY"));
+ if (registry_file == NULL) {
+ registry_file = g_build_filename (g_get_home_dir (),
+- ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".xml", NULL);
++ ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".bin", NULL);
+ }
+ #ifdef HAVE_FORK
+ if (g_getenv ("GST_REGISTRY_FORK") == NULL
+diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h gstreamer-0.10.9/gst/gstregistry.h
+--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h 2006-07-11 21:16:04.000000000 +0100
++++ gstreamer-0.10.9/gst/gstregistry.h 2006-09-01 12:30:36.000000000 +0100
+@@ -105,8 +105,8 @@
+ GstPlugin * gst_registry_lookup (GstRegistry *registry, const char *filename);
+ GstPluginFeature * gst_registry_lookup_feature (GstRegistry *registry, const char *name);
+
+-gboolean gst_registry_xml_read_cache (GstRegistry * registry, const char *location);
+-gboolean gst_registry_xml_write_cache (GstRegistry * registry, const char *location);
++gboolean gst_registry_binary_read_cache (GstRegistry * registry, const char *location);
++gboolean gst_registry_binary_write_cache (GstRegistry * registry, const char *location);
+
+ void _gst_registry_remove_cache_plugins (GstRegistry *registry);
+
+diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am gstreamer-0.10.9/gst/Makefile.am
+--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am 2006-07-13 16:31:47.000000000 +0100
++++ gstreamer-0.10.9/gst/Makefile.am 2006-09-01 12:30:36.000000000 +0100
+@@ -9,7 +9,7 @@
+ if GST_DISABLE_REGISTRY
+ GST_REGISTRY_SRC =
+ else
+-GST_REGISTRY_SRC = gstregistryxml.c
++GST_REGISTRY_SRC = gstregistrybinary.c
+ endif
+
+ if GST_DISABLE_PARSE
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch
new file mode 100644
index 000000000..9f5d850f5
--- /dev/null
+++ b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch
@@ -0,0 +1,24 @@
+Index: gstreamer-0.10.4/gst/gstregistry.c
+===================================================================
+RCS file: /cvs/gstreamer/gstreamer/gst/gstregistry.c,v
+retrieving revision 1.75
+diff -u -r1.75 gstregistry.c
+--- gstreamer-0.10.4/gst/gstregistry.c 31 Jul 2007 11:51:38 -0000 1.75
++++ gstreamer-0.10.4/gst/gstregistry.c 8 Jan 2008 14:12:40 -0000
+@@ -813,6 +813,16 @@
+ GST_LOG_OBJECT (registry, "examining file: %s", filename);
+
+ if (g_file_test (filename, G_FILE_TEST_IS_DIR)) {
++ /*
++ * skip .debug directories, these contain elf files that can crash
++ * dlopen
++ */
++ if (g_str_equal (dirent, ".debug")) {
++ GST_LOG_OBJECT (registry, "found .debug directory, ignoring");
++ g_free (filename);
++ continue;
++ }
++
+ if (level > 0) {
+ GST_LOG_OBJECT (registry, "found directory, recursing");
+ changed |= gst_registry_scan_path_level (registry, filename, level - 1);