summaryrefslogtreecommitdiff
path: root/meta/packages/gtk+
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-07-26 16:12:11 +0000
committerRoss Burton <ross@openedhand.com>2007-07-26 16:12:11 +0000
commit7d9c3749e535cb5b51402299d58bab4104880d8f (patch)
tree4ed3cb07d8361edde6596b1e950e4f57eb368df4 /meta/packages/gtk+
parent24f13ade828c10aee426164e9a35d455027e3358 (diff)
downloadopenembedded-core-7d9c3749e535cb5b51402299d58bab4104880d8f.tar.gz
openembedded-core-7d9c3749e535cb5b51402299d58bab4104880d8f.tar.bz2
openembedded-core-7d9c3749e535cb5b51402299d58bab4104880d8f.tar.xz
openembedded-core-7d9c3749e535cb5b51402299d58bab4104880d8f.zip
Add a bit of a hack patch to disable frantic redrawing of GtkRange when they move, so that the contents has a change on slower devices
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2234 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gtk+')
-rw-r--r--meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch17
-rw-r--r--meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch18
-rw-r--r--meta/packages/gtk+/gtk+_2.10.12.bb3
-rw-r--r--meta/packages/gtk+/gtk+_2.6.10.bb3
4 files changed, 39 insertions, 2 deletions
diff --git a/meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch b/meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch
new file mode 100644
index 000000000..384d71b4f
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch
@@ -0,0 +1,17 @@
+Index: gtk/gtkrange.c
+===================================================================
+--- gtk/gtkrange.c (revision 18523)
++++ gtk/gtkrange.c (working copy)
+@@ -1979,8 +1979,12 @@
+ gtk_widget_queue_draw (GTK_WIDGET (range));
+
+ /* This is so we don't lag the widget being scrolled. */
++#if 0
++ /* Disable this, the scroll bar lags a bit but the end result is that
++ scrolling treeviews is *a lot* smoother. See GNOME #460534. */
+ if (GTK_WIDGET_REALIZED (range))
+ gdk_window_process_updates (GTK_WIDGET (range)->window, FALSE);
++#endif
+ }
+
+ /* Note that we don't round off to range->round_digits here.
diff --git a/meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch b/meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch
new file mode 100644
index 000000000..d16871228
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch
@@ -0,0 +1,18 @@
+Index: gtk/gtkrange.c
+===================================================================
+--- gtk/gtkrange.c (revision 18542)
++++ gtk/gtkrange.c (working copy)
+@@ -1569,9 +1569,12 @@
+
+ gtk_widget_queue_draw (GTK_WIDGET (range));
+ /* This is so we don't lag the widget being scrolled. */
++#if 0
++ /* Disable this, the scroll bar lags a bit but the end result is that
++ scrolling treeviews is *a lot* smoother. See GNOME #460534. */
+ if (GTK_WIDGET_REALIZED (range))
+ gdk_window_process_updates (GTK_WIDGET (range)->window, FALSE);
+-
++#endif
+ /* Note that we don't round off to range->round_digits here.
+ * that's because it's really broken to change a value
+ * in response to a change signal on that value; round_digits
diff --git a/meta/packages/gtk+/gtk+_2.10.12.bb b/meta/packages/gtk+/gtk+_2.10.12.bb
index 64241a79b..014028617 100644
--- a/meta/packages/gtk+/gtk+_2.10.12.bb
+++ b/meta/packages/gtk+/gtk+_2.10.12.bb
@@ -1,7 +1,7 @@
require gtk+.inc
DEPENDS += "cairo"
-PR = "r11"
+PR = "r12"
# disable per default - untested and not all patches included.
DEFAULT_PREFERENCE = "-1"
@@ -23,6 +23,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
file://entry-cairo.patch;patch=1;pnum=0 \
file://toggle-font.diff;patch=1;pnum=0 \
file://combo-arrow-size.patch;patch=1;pnum=0 \
+ file://range-no-redraw.patch;patch=1;pnum=0 \
file://scrolled-placement.patch;patch=1;pnum=0"
# file://scroll-timings.patch;patch=1 \
# file://pangoxft2.10.6.diff;patch=1"
diff --git a/meta/packages/gtk+/gtk+_2.6.10.bb b/meta/packages/gtk+/gtk+_2.6.10.bb
index 0ec21848f..d7199ef1d 100644
--- a/meta/packages/gtk+/gtk+_2.6.10.bb
+++ b/meta/packages/gtk+/gtk+_2.6.10.bb
@@ -1,6 +1,6 @@
require gtk+.inc
-PR = "r11"
+PR = "r12"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://no-demos.patch;patch=1 \
@@ -17,6 +17,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://filechooser-default.patch;patch=1 \
file://toggle-font.diff;patch=1;pnum=0 \
file://combo-arrow-size.patch;patch=1;pnum=0 \
+ file://range-no-redraw.patch;patch=1;pnum=0 \
"
EXTRA_OECONF = "--without-libtiff --disable-xkb --disable-glibtest"